summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild')
-rw-r--r--dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild b/dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild
new file mode 100644
index 000000000000..98090a1bfc83
--- /dev/null
+++ b/dev-ruby/snaky_hash/snaky_hash-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="snaky_hash.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Hashie::Mash joint to make #snakelife better"
+HOMEPAGE="https://gitlab.com/oauth-xx/snaky_hash"
+SRC_URI="https://gitlab.com/oauth-xx/snaky_hash/-/archive/v${PV}/snaky_hash-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+RUBY_S="snaky_hash-v${PV}"
+IUSE=""
+SLOT="1"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend "
+ dev-ruby/hashie:*
+ >=dev-ruby/version_gem-1.1.1:1
+"
+
+ruby_add_depend "test? ( >=dev-ruby/rspec-pending_for-0.1:0 )"
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e 's/if RUN_COVERAGE/if false/' spec/spec_helper.rb || die
+}