summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/stomp')
-rw-r--r--dev-ruby/stomp/Manifest1
-rw-r--r--dev-ruby/stomp/files/stomp-1.4.10-rspec-3.12.patch149
-rw-r--r--dev-ruby/stomp/stomp-1.4.10-r1.ebuild (renamed from dev-ruby/stomp/stomp-1.4.9.ebuild)11
-rw-r--r--dev-ruby/stomp/stomp-1.4.10.ebuild27
4 files changed, 156 insertions, 32 deletions
diff --git a/dev-ruby/stomp/Manifest b/dev-ruby/stomp/Manifest
index 055b7586488f..b0e928f9c22b 100644
--- a/dev-ruby/stomp/Manifest
+++ b/dev-ruby/stomp/Manifest
@@ -1,2 +1 @@
DIST stomp-1.4.10.gem 99840 BLAKE2B 5dc2b18d7551629dccb599a77934bffcf92d83158b6797a1645f5fd8af6c4738e1d8d97d5a6c6bb6655c19f98accd4ecdee0677096f9a5e89bdf0295532a1087 SHA512 bff1a533e5455cf4540bab3b5d16c63f1e0783b0257b5e0bf2fd26512586670ce5db66f97e098805c7b5fc02913478553409b90a4014bdc883465bc7b474eb7e
-DIST stomp-1.4.9.gem 99328 BLAKE2B 9aa50880224cede15be69657ec7ecccf1a075db3e51de55faf3a0ba50335b90b910d1202c646585229cc35c0e2e4cf01fd99774960d9ae90ff82030c4bac6a69 SHA512 e1e3aed86621e2dac199fd7e4ba67fedc3582b5cfe9e4ff2efbdc9c545bb25d2c52391d9403e2fa935f69635e85bd3c1ca29d2d5b3c425aa850d3ccb8f7a5e86
diff --git a/dev-ruby/stomp/files/stomp-1.4.10-rspec-3.12.patch b/dev-ruby/stomp/files/stomp-1.4.10-rspec-3.12.patch
new file mode 100644
index 000000000000..f7f1ca39016b
--- /dev/null
+++ b/dev-ruby/stomp/files/stomp-1.4.10-rspec-3.12.patch
@@ -0,0 +1,149 @@
+https://github.com/stompgem/stomp/pull/175
+
+From 299923281d02e544ca386a9883e87c395135d3af Mon Sep 17 00:00:00 2001
+From: Steve Traylen <steve.traylen@cern.ch>
+Date: Thu, 30 Mar 2023 13:36:52 +0200
+Subject: [PATCH] Fix tests failing with rspec 3.12
+
+Patch from
+
+* https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1027092
+* https://salsa.debian.org/ruby-team/ruby-stomp/-/commit/5be6383a7a34a1d1891708d6aa8688cb4a6f89a5
+
+resolves rspec failure:
+
+```
+$ rspec --fail-fast spec/client_spec.rb
+RSpec version: 3.8.0
+Traceback (most recent call last):
+ 9: from /home/straylen/pkgs/rubygem-stomp/stomp-1.4.9/lib/client/utils.rb:194:in `block in start_listeners'
+ 8: from /home/straylen/pkgs/rubygem-stomp/stomp-1.4.9/lib/client/utils.rb:194:in `loop'
+ 7: from /home/straylen/pkgs/rubygem-stomp/stomp-1.4.9/lib/client/utils.rb:195:in `block (2 levels) in start_listeners'
+ 6: from /usr/share/gems/gems/rspec-mocks-3.8.1/lib/rspec/mocks/test_double.rb:102:in `method_missing'
+ 5: from /usr/share/gems/gems/rspec-mocks-3.8.1/lib/rspec/mocks/proxy.rb:202:in `raise_unexpected_message_error'
+ 4: from /usr/share/gems/gems/rspec-mocks-3.8.1/lib/rspec/mocks/error_generator.rb:50:in `raise_unexpected_message_error'
+ 3: from /usr/share/gems/gems/rspec-mocks-3.8.1/lib/rspec/mocks/error_generator.rb:311:in `__raise'
+ 2: from /usr/share/gems/gems/rspec-mocks-3.8.1/lib/rspec/mocks/error_generator.rb:327:in `notify'
+ 1: from /usr/share/gems/gems/rspec-support-3.8.2/lib/rspec/support.rb:106:in `notify_failure'
+/usr/share/gems/gems/rspec-support-3.8.2/lib/rspec/support.rb:97:in `block in <module:Support>': #<Double "connection"> received unexpected message :receive with (no args) (RSpec::Mocks::MockExpectationError)
+.#<Thread:0x000055a54150bd60@/home/straylen/pkgs/rubygem-stomp/stomp-1.4.9/lib/client/utils.rb:193 run> terminated with exception (report_on_exception is true):
+Traceback (most recent call last):
+ 6: from /home/straylen/pkgs/rubygem-stomp/stomp-1.4.9/lib/client/utils.rb:194:in `block in start_listeners'
+ 5: from /home/straylen/pkgs/rubygem-stomp/stomp-1.4.9/lib/client/utils.rb:194:in `loop'
+```
+
+Fixes: #164
+--- a/spec/client_spec.rb
++++ b/spec/client_spec.rb
+@@ -136,13 +136,13 @@
+ end
+
+ it "should properly parse the URL provided" do
+- expect(Stomp::Connection).to receive(:new).with(:hosts => [{:login => 'testlogin',
++ expect(Stomp::Connection).to receive(:new).with({:hosts => [{:login => 'testlogin',
+ :passcode => 'testpassword',
+ :host => 'localhost',
+ :port => 12345}],
+ :logger => null_logger,
+ :reliable => false,
+- :client_main => @cli_thread)
++ :client_main => @cli_thread})
+ Stomp::Client.new('testlogin', 'testpassword', 'localhost', '12345', false)
+ end
+
+@@ -157,13 +157,13 @@
+ end
+
+ it "should properly parse the URL provided" do
+- expect(Stomp::Connection).to receive(:new).with(:hosts => [{:login => '',
++ expect(Stomp::Connection).to receive(:new).with({:hosts => [{:login => '',
+ :passcode => '',
+ :host => 'foobar',
+ :port => 12345}],
+ :logger => null_logger,
+ :reliable => false,
+- :client_main => @cli_thread)
++ :client_main => @cli_thread})
+ Stomp::Client.new('stomp://foobar:12345')
+ end
+
+@@ -179,13 +179,13 @@
+ end
+
+ it "should properly parse the URL provided" do
+- expect(Stomp::Connection).to receive(:new).with(:hosts => [{:login => '',
++ expect(Stomp::Connection).to receive(:new).with({:hosts => [{:login => '',
+ :passcode => '',
+ :host => 'foo-bar',
+ :port => 12345}],
+ :logger => null_logger,
+ :reliable => false,
+- :client_main => @cli_thread)
++ :client_main => @cli_thread})
+ Stomp::Client.new('stomp://foo-bar:12345')
+ end
+
+@@ -201,13 +201,13 @@
+ end
+
+ it "should properly parse the URL provided" do
+- expect(Stomp::Connection).to receive(:new).with(:hosts => [{:login => 'test-login',
++ expect(Stomp::Connection).to receive(:new).with({:hosts => [{:login => 'test-login',
+ :passcode => 'testpasscode',
+ :host => 'foobar',
+ :port => 12345}],
+ :logger => null_logger,
+ :reliable => false,
+- :client_main => @cli_thread)
++ :client_main => @cli_thread})
+ Stomp::Client.new('stomp://test-login:testpasscode@foobar:12345')
+ end
+
+@@ -223,13 +223,13 @@
+ end
+
+ it "should properly parse the URL provided" do
+- expect(Stomp::Connection).to receive(:new).with(:hosts => [{:login => 'test-login',
++ expect(Stomp::Connection).to receive(:new).with({:hosts => [{:login => 'test-login',
+ :passcode => 'testpasscode',
+ :host => 'foo-bar',
+ :port => 12345}],
+ :logger => null_logger,
+ :reliable => false,
+- :client_main => @cli_thread)
++ :client_main => @cli_thread})
+ Stomp::Client.new('stomp://test-login:testpasscode@foo-bar:12345')
+ end
+
+@@ -248,13 +248,13 @@
+ end
+
+ it "should properly parse the URL provided" do
+- expect(Stomp::Connection).to receive(:new).with(:hosts => [{:login => '',
++ expect(Stomp::Connection).to receive(:new).with({:hosts => [{:login => '',
+ :passcode => '',
+ :host => 'host.foobar.com',
+ :port => 12345}],
+ :logger => null_logger,
+ :reliable => false,
+- :client_main => @cli_thread)
++ :client_main => @cli_thread})
+ Stomp::Client.new('stomp://host.foobar.com:12345')
+ end
+
+@@ -270,13 +270,13 @@
+ end
+
+ it "should properly parse the URL provided" do
+- expect(Stomp::Connection).to receive(:new).with(:hosts => [{:login => 'testlogin',
++ expect(Stomp::Connection).to receive(:new).with({:hosts => [{:login => 'testlogin',
+ :passcode => 'testpasscode',
+ :host => 'host.foobar.com',
+ :port => 12345}],
+ :logger => null_logger,
+ :reliable => false,
+- :client_main => @cli_thread)
++ :client_main => @cli_thread})
+ Stomp::Client.new('stomp://testlogin:testpasscode@host.foobar.com:12345')
+ end
+
diff --git a/dev-ruby/stomp/stomp-1.4.9.ebuild b/dev-ruby/stomp/stomp-1.4.10-r1.ebuild
index cd1e6a88a687..b3d25fc0bea1 100644
--- a/dev-ruby/stomp/stomp-1.4.9.ebuild
+++ b/dev-ruby/stomp/stomp-1.4.10-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
@@ -18,7 +18,10 @@ HOMEPAGE="https://github.com/stompgem/stomp"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.10-rspec-3.12.patch
+)
all_ruby_prepare() {
# Skip specs that hang the test run indefinitely, most likely
diff --git a/dev-ruby/stomp/stomp-1.4.10.ebuild b/dev-ruby/stomp/stomp-1.4.10.ebuild
deleted file mode 100644
index 67495063da29..000000000000
--- a/dev-ruby/stomp/stomp-1.4.10.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby bindings for the stomp messaging protocol"
-HOMEPAGE="https://github.com/stompgem/stomp"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-all_ruby_prepare() {
- # Skip specs that hang the test run indefinitely, most likely
- # because of rspec-mocks deprecation output
- rm -f spec/connection_spec.rb || die
-}