summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/stringex')
-rw-r--r--dev-ruby/stringex/Manifest1
-rw-r--r--dev-ruby/stringex/metadata.xml8
-rw-r--r--dev-ruby/stringex/stringex-2.5.2.ebuild51
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/stringex/Manifest b/dev-ruby/stringex/Manifest
new file mode 100644
index 000000000000..80ea04191a3d
--- /dev/null
+++ b/dev-ruby/stringex/Manifest
@@ -0,0 +1 @@
+DIST stringex-2.5.2.gem 128000 SHA256 27a8ee92a808a83284438e51ed391f3539ae6b39731b95cb4ad940974f6d0a94 SHA512 06905b5d59b40f59c0901bbaacbf303cd906be110cd69a4b8cc29cecd69b6aa73d80cee0c9c0e2014f662b9fca1611c0fe334fcba3c4fa686224dac94f4e0d41 WHIRLPOOL 21a66f7babd2424035e4874d9f5168736c81f6da8388764633d9618064998bfeb076076cfd0d9125583903be25070fa329c4e8fccd81ebb8f801c4447e6be7b4
diff --git a/dev-ruby/stringex/metadata.xml b/dev-ruby/stringex/metadata.xml
new file mode 100644
index 000000000000..83a4eee626dc
--- /dev/null
+++ b/dev-ruby/stringex/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rsl/stringex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/stringex/stringex-2.5.2.ebuild b/dev-ruby/stringex/stringex-2.5.2.ebuild
new file mode 100644
index 000000000000..6b8c115e1c3f
--- /dev/null
+++ b/dev-ruby/stringex/stringex-2.5.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_DOC_DIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extensions for Ruby's String class"
+HOMEPAGE="https://github.com/rsl/stringex"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+# we could rely on activerecord[sqlite3], but since we do not remove the
+# sqlite3 adapter from activerecord when building -sqlite3, it's easier
+# to just add another dependency, so the user doesn't have to change the
+# USE flags at all.
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/i18n-0.6.9:0.6
+ dev-ruby/redcloth
+ dev-ruby/test-unit:2
+ )"
+
+USE_RUBY=${USE_RUBY/ruby22/} ruby_add_bdepend "test? ( >=dev-ruby/activerecord-3 dev-ruby/sqlite3 )"
+
+all_ruby_prepare() {
+ sed -i -e '1agem "i18n", "~>0.6.9"' test/test_helper.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby22)
+ # Avoid tests depending on Rails until we have a version
+ # keyworded.
+ rm -rf test/unit/{acts_as_url,localization}* || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # rake seems to break this
+ ruby-ng_testrb-2 -Ilib -Itest test/unit/*/*_test.rb test/performance/*_test.rb || die "tests failed"
+}