summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/terminal-table/terminal-table-2.0.0.ebuild')
-rw-r--r--dev-ruby/terminal-table/terminal-table-2.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/terminal-table/terminal-table-2.0.0.ebuild b/dev-ruby/terminal-table/terminal-table-2.0.0.ebuild
new file mode 100644
index 000000000000..8e50ad85b62c
--- /dev/null
+++ b/dev-ruby/terminal-table/terminal-table-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc Todo.rdoc"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, feature rich ascii table generation library"
+HOMEPAGE="https://github.com/tj/terminal-table"
+SRC_URI="https://github.com/tj/terminal-table/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm64"
+SLOT="2"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/unicode-display_width-1.1.1:1"
+
+ruby_add_bdepend "test? ( dev-ruby/term-ansicolor )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}