summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/test-unit/test-unit-3.6.0.ebuild')
-rw-r--r--dev-ruby/test-unit/test-unit-3.6.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/test-unit/test-unit-3.6.0.ebuild b/dev-ruby/test-unit/test-unit-3.6.0.ebuild
deleted file mode 100644
index 8878b923983d..000000000000
--- a/dev-ruby/test-unit/test-unit-3.6.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_EXTRADOC="README.md doc-install/text/*.md"
-
-RUBY_FAKEGEM_GEMSPEC="test-unit.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An xUnit family unit testing framework for Ruby"
-HOMEPAGE="https://rubygems.org/gems/test-unit"
-SRC_URI="https://github.com/test-unit/test-unit/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Ruby-BSD BSD-2 ) PSF-2"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend "dev-ruby/power_assert"
-
-all_ruby_prepare() {
- mv doc doc-install || die "moving doc directory out of the way failed"
-}
-
-each_ruby_test() {
- ${RUBY} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb-3 testrb-2
-}