summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/timecop/timecop-0.9.1.ebuild')
-rw-r--r--dev-ruby/timecop/timecop-0.9.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-ruby/timecop/timecop-0.9.1.ebuild b/dev-ruby/timecop/timecop-0.9.1.ebuild
deleted file mode 100644
index 8dcc984dd743..000000000000
--- a/dev-ruby/timecop/timecop-0.9.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.markdown"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
-HOMEPAGE="https://github.com/travisjeffery/timecop"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 sparc x86"
-IUSE=""
-
-# Missing testdep activesupport
-ruby_add_bdepend "test? ( dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
- sed -i -e '/rubygems/ a\gem "test-unit"' \
- -e '/minitest\/rg/ s:^:#:' test/test_helper.rb || die
- # FIXME after activesupport gained ruby22 support
- rm test/time_stack_item_test.rb || die
-}
-
-each_ruby_test() {
- for f in test/*_test.rb ; do
- ${RUBY} -Ilib $f || die
- done
-}