summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/timers/timers-4.3.3.ebuild')
-rw-r--r--dev-ruby/timers/timers-4.3.3.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/timers/timers-4.3.3.ebuild b/dev-ruby/timers/timers-4.3.3.ebuild
deleted file mode 100644
index fe52c2bb6f01..000000000000
--- a/dev-ruby/timers/timers-4.3.3.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="timers.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Pure Ruby one-shot and periodic timers"
-HOMEPAGE="https://github.com/tarcieri/timers"
-SRC_URI="https://github.com/tarcieri/timers/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-all_ruby_prepare() {
- sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
- sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
-
- # Avoid performance specs to avoid ruby-prof dependency and
- # because we cannot provide a good environment for performance testing.
- rm -f spec/timers/performance_spec.rb || die
-}