summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tins/tins-1.24.1.ebuild')
-rw-r--r--dev-ruby/tins/tins-1.24.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/tins/tins-1.24.1.ebuild b/dev-ruby/tins/tins-1.24.1.ebuild
new file mode 100644
index 000000000000..0ae7ba411b98
--- /dev/null
+++ b/dev-ruby/tins/tins-1.24.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library"
+HOMEPAGE="https://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Earlier versions of ruby bundled this dependency
+USE_RUBY="ruby26 ruby27" ruby_add_rdepend "dev-ruby/sync"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}