summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tty-screen/tty-screen-0.8.0.ebuild')
-rw-r--r--dev-ruby/tty-screen/tty-screen-0.8.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/tty-screen/tty-screen-0.8.0.ebuild b/dev-ruby/tty-screen/tty-screen-0.8.0.ebuild
new file mode 100644
index 000000000000..8ed94995bac7
--- /dev/null
+++ b/dev-ruby/tty-screen/tty-screen-0.8.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="tty-screen.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal screen size detection which works on Linux, OS X and Windows/Cygwin"
+HOMEPAGE="https://github.com/piotrmurach/tty-screen"
+SRC_URI="https://github.com/piotrmurach/tty-screen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:require_relative ":require "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+ rm -f spec/perf/size_spec.rb || die
+}