summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tzinfo/tzinfo-0.3.52.ebuild')
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.52.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.52.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.52.ebuild
new file mode 100644
index 000000000000..773c9ea68d86
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.52.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby23 -> fails tests
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.github.io/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+all_ruby_prepare() {
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i \
+ -e '/^ def test_get_tainted_not_loaded/, /^ end/ s:^:#:' \
+ "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+each_ruby_test() {
+ TZ='America/Los_Angeles' ${RUBY} -I. -S testrb test/tc_*.rb || die
+}