summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/unindent/unindent-1.0-r2.ebuild')
-rw-r--r--dev-ruby/unindent/unindent-1.0-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/unindent/unindent-1.0-r2.ebuild b/dev-ruby/unindent/unindent-1.0-r2.ebuild
new file mode 100644
index 000000000000..c3312706bb8e
--- /dev/null
+++ b/dev-ruby/unindent/unindent-1.0-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby method to unindent strings"
+HOMEPAGE="https://github.com/mynyml/unindent"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+ruby_add_bdepend "test? ( dev-ruby/nanotest )"
+
+each_ruby_test() {
+ ${RUBY} -I.:lib test/test_unindent.rb || die
+}