summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/vcr/vcr-3.0.1.ebuild')
-rw-r--r--dev-ruby/vcr/vcr-3.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/vcr/vcr-3.0.1.ebuild b/dev-ruby/vcr/vcr-3.0.1.ebuild
new file mode 100644
index 000000000000..ea0e15318cd9
--- /dev/null
+++ b/dev-ruby/vcr/vcr-3.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md README.md Upgrade.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Records your test suite's HTTP interactions and replay them during test runs"
+HOMEPAGE="https://github.com/vcr/vcr/"
+SRC_URI="https://github.com/vcr/vcr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="3"
+IUSE="test"
+
+# Tests require all supported HTTP libraries to be present, and it is
+# not possible to avoid some of them without very extensive patches.
+RESTRICT="test"