summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/vcr/vcr-6.2.0.ebuild')
-rw-r--r--dev-ruby/vcr/vcr-6.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/vcr/vcr-6.2.0.ebuild b/dev-ruby/vcr/vcr-6.2.0.ebuild
new file mode 100644
index 000000000000..72776069a303
--- /dev/null
+++ b/dev-ruby/vcr/vcr-6.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CONTRIBUTING.md README.md Upgrade.md"
+
+RUBY_FAKEGEM_GEMSPEC="vcr.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Records your test suite's HTTP interactions and replay them during test runs"
+HOMEPAGE="https://github.com/vcr/vcr/"
+SRC_URI="https://github.com/vcr/vcr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
+SLOT="$(ver_cut 1)"
+IUSE="json test"
+
+# Tests require all supported HTTP libraries to be present, and it is
+# not possible to avoid some of them without very extensive patches.
+RESTRICT="test"
+
+ruby_add_rdepend "json? ( dev-ruby/json )"