summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/web-console/web-console-3.7.0.ebuild')
-rw-r--r--dev-ruby/web-console/web-console-3.7.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/web-console/web-console-3.7.0.ebuild b/dev-ruby/web-console/web-console-3.7.0.ebuild
new file mode 100644
index 000000000000..1228f004d912
--- /dev/null
+++ b/dev-ruby/web-console/web-console-3.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.markdown README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="web-console.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A debugging tool for your Ruby on Rails applications"
+HOMEPAGE="https://github.com/rails/web-console"
+SRC_URI="https://github.com/rails/web-console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/actionview-5.0:*
+ >=dev-ruby/activemodel-5.0:*
+ >=dev-ruby/bindex-0.4.0
+ >=dev-ruby/railties-5.0:*
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ >=dev-ruby/rails-5.0
+ dev-ruby/sqlite3
+ dev-ruby/mocha
+ www-servers/puma
+)"
+
+all_ruby_prepare() {
+ # Use an installed rails version rather than live source from github.
+ sed -i -e '/\(rack\|rails\|simplecov\)/ s/,/#/' \
+ -e '/\(byebug\|simplecov\)/ s:^:#:' Gemfile || die
+
+ sed -i -e '/simplecov/I s:^:#:' test/test_helper.rb || die
+}