summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/http-cookie/Manifest1
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/Manifest b/dev-ruby/http-cookie/Manifest
index c387366caeae..01b5b1ddd5be 100644
--- a/dev-ruby/http-cookie/Manifest
+++ b/dev-ruby/http-cookie/Manifest
@@ -1 +1,2 @@
DIST http-cookie-1.0.3.gem 38400 BLAKE2B 6b7292b2a5d7c37b6769cdd38f01d8cf78aa9557b4a204d736dffeae5d31768c57ac58f00577df78252f9a8bdb12a7faecf5e1be64c8ee29aaf67cc9307d0a35 SHA512 43ac1218e98dd47ee22e33e72e20bc5b55f65e60aadd417641f8a4221eba88995d418c7738a4c35dfba132e05c0c4b0df2b2bedd56c22e82c062d1f03de0052f
+DIST http-cookie-1.0.4.gem 39424 BLAKE2B 06ac0e667340ac17827a8eb4ed320efe77ad97509fcd444f7e77d887a77643a6b34e84486db78eba52245891d1719e750d9a446c40a4ab7804f2304b600029bd SHA512 788fdaa642e6b596e7a91c57a7942a832c09a84fed88b30fdd8e5a8ad66d72780afc1246e6c83c4dfd5af8018c278750866dd05d804aef793aa067b09519af8d
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.4.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.4.ebuild
new file mode 100644
index 000000000000..d4c813797e61
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}