summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/parallel/Manifest4
-rw-r--r--dev-ruby/parallel/parallel-1.12.1.ebuild55
-rw-r--r--dev-ruby/parallel/parallel-1.13.0.ebuild55
-rw-r--r--dev-ruby/parallel/parallel-1.14.0.ebuild55
-rw-r--r--dev-ruby/parallel/parallel-1.15.0.ebuild55
5 files changed, 0 insertions, 224 deletions
diff --git a/dev-ruby/parallel/Manifest b/dev-ruby/parallel/Manifest
index dc5bc02faec1..db917a36f46e 100644
--- a/dev-ruby/parallel/Manifest
+++ b/dev-ruby/parallel/Manifest
@@ -1,6 +1,2 @@
-DIST parallel-1.12.1.tar.gz 20499 BLAKE2B f0fa25b9fe65e44804854f703dd2d80e53572e64c2072c418d0462922bd04f89cff0e023caf4293d8a1504ad66a2a29ebbdd01920fc6fe400837859da0f0eb78 SHA512 f0ab332dfa60bb3190bba8275dbdf7b54d3de205ab76099d11f0a64e1fc28e1ba7e72d1a242bd615015c2d09a3f08df01c382869fd6990b854b01fe182245857
-DIST parallel-1.13.0.tar.gz 20771 BLAKE2B ca0070492d7e15800bab751c8c1e8b0f88e89310f8455a3e6197a6b572efc1c691d9584eac7d199caa66a4b32eb49f4e7f4bdcae59c5c08f9c61ab3d60fc469f SHA512 7fec6eb3ee6ae06390f1a444a24ec3350e0562772d9ce654f126875b36e6cab42703f85978a08889e3a25c4f1d8a95d8a67c78b3ab9ac75c7ca6e198311f797d
-DIST parallel-1.14.0.tar.gz 20361 BLAKE2B 55d7d58f6036485fc513bd6fd784bd6d6e8a8fd96b4ab892849c4a47afda5fd6f71f8560c4db23e20c1c6de85c7606f48edbb440aa386a10963737c099444d58 SHA512 fe6d526eeabb07a86523118be232b31a7d0d8de38a70927e6741a112538c29a239cdc4490355fcc09740ca9620a1c2aea43498e33ee38e617f4ac64b8320ed9f
-DIST parallel-1.15.0.tar.gz 20420 BLAKE2B 9eecba1a6ecda4a07a18cce8c04c9777c0dfe9197d0c91b3abd9f8f5e66c47943727671ed4f39b6169e00f945d5bcd4ed182d0f9fdd0ae196d76316bf7789c69 SHA512 1acc2d3585d89f6fe64f70b0eec96ca6838477d64fe5be827479dc3178a9cce33ef3309aa7fb09669c811a95f6251a112455c2c9096e108783d955f75fe523e6
DIST parallel-1.16.2.tar.gz 20853 BLAKE2B 4d30dd43f854ca9c3a6b739a36f250374a527d00c12e1221e5cb5a9da06fda66b0fadaaf7b9b5f5ac69549e9b1c75eb8f1c17a4bcd160ba15086013884176c07 SHA512 0d3cd59527ab1ff9da995f71cf2c04d6eec5276d5dcbab8b62844e18c3cf83de9b288c0f184d26dcf2897539bba2a6ac58fd0efb02952cc7999f411c3efb5b33
DIST parallel-1.17.0.tar.gz 20882 BLAKE2B a8afb329de1d8d0d577c1b53d990c4f1cd8ec9f23b8cc1005310903954f180c52535e3d8a5901862f1504da0981f3e16cf73a848403ed49872aa3dc45781b888 SHA512 92c7f4475a791da4feb0afda3686a4f9e9cc397ac278560c177552abf586054594d29a67b583845b69433e7824c0ce36bcffe98e13051242db0e5ee4a3c7a17c
diff --git a/dev-ruby/parallel/parallel-1.12.1.ebuild b/dev-ruby/parallel/parallel-1.12.1.ebuild
deleted file mode 100644
index 05fc01153dbe..000000000000
--- a/dev-ruby/parallel/parallel-1.12.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
- test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:5.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
- # Make sure the correct ruby is used for testing
- sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e '1i require "tempfile"; gem "activerecord", "~>5.2.0"' spec/cases/helper.rb || die
- sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
- # Avoid a failing spec regarding to pipes. The spec seems like it
- # should always fail.
- sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
- -i spec/parallel_spec.rb || die
-
- # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
- sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-
- # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
- sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
- # Set RUBYLIB explicitly for the ruby's that get started from the specs.
- TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}
diff --git a/dev-ruby/parallel/parallel-1.13.0.ebuild b/dev-ruby/parallel/parallel-1.13.0.ebuild
deleted file mode 100644
index 471513dfe1f1..000000000000
--- a/dev-ruby/parallel/parallel-1.13.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
- test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:5.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
- # Make sure the correct ruby is used for testing
- sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e '1i require "tempfile"; gem "activerecord", "~>5.2.0"' spec/cases/helper.rb || die
- sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
- # Avoid a failing spec regarding to pipes. The spec seems like it
- # should always fail.
- sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
- -i spec/parallel_spec.rb || die
-
- # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
- sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-
- # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
- sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
- # Set RUBYLIB explicitly for the ruby's that get started from the specs.
- TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}
diff --git a/dev-ruby/parallel/parallel-1.14.0.ebuild b/dev-ruby/parallel/parallel-1.14.0.ebuild
deleted file mode 100644
index 471513dfe1f1..000000000000
--- a/dev-ruby/parallel/parallel-1.14.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
- test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:5.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
- # Make sure the correct ruby is used for testing
- sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e '1i require "tempfile"; gem "activerecord", "~>5.2.0"' spec/cases/helper.rb || die
- sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
- # Avoid a failing spec regarding to pipes. The spec seems like it
- # should always fail.
- sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
- -i spec/parallel_spec.rb || die
-
- # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
- sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-
- # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
- sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
- # Set RUBYLIB explicitly for the ruby's that get started from the specs.
- TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}
diff --git a/dev-ruby/parallel/parallel-1.15.0.ebuild b/dev-ruby/parallel/parallel-1.15.0.ebuild
deleted file mode 100644
index 471513dfe1f1..000000000000
--- a/dev-ruby/parallel/parallel-1.15.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
- test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:5.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
- # Make sure the correct ruby is used for testing
- sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' \
- -e '1i require "tempfile"; gem "activerecord", "~>5.2.0"' spec/cases/helper.rb || die
- sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
- # Avoid a failing spec regarding to pipes. The spec seems like it
- # should always fail.
- sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
- -i spec/parallel_spec.rb || die
-
- # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
- sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-
- # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
- sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
- # Set RUBYLIB explicitly for the ruby's that get started from the specs.
- TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}