summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/Manifest2
-rw-r--r--dev-ruby/activesupport/activesupport-6.0.4.1.ebuild75
-rw-r--r--dev-ruby/activesupport/activesupport-6.0.4.8.ebuild75
3 files changed, 0 insertions, 152 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index c81cae520f54..7cd07ead5a6e 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,6 +1,4 @@
DIST rails-5.2.8.tgz 8847449 BLAKE2B 11937ee2aeea39cade43829a01430315a997fef070fc73a1e63baaff8b3631f82561c7acdd44cf1981501424be68d814001dd26cbf7678ca987a8311d109d367 SHA512 98e1b36bdd4235e983d0805b6ff9779e3793d1bed486dc6de854215c4294334d5036157a527c1222cc2be4c107754553dadf2bf86e65ce6561dd8152c47ef84a
-DIST rails-6.0.4.1.tgz 18595307 BLAKE2B 9a950a45cd04c5fe0cbe57fd014a6997074dcbe8f95fcbb2f5d3b6372867ef8bb0931b909ca8eba623787419f5f45504cdcd477729ba3b3a052f5003229121cd SHA512 322cfa6d0ed62f0660ce2f43003b2a745297f3b82dca486d7e4a9821441ad4ec92c202556515645d141fba31c998e17aa00bbe3d8c2106718e6839f94e88c975
-DIST rails-6.0.4.8.tgz 18574385 BLAKE2B be6ea79fa452831e1c17ed550f875500c4b00ebf04223335abe8b1e42738f96e6d62ded24913501042a165833235082fde8865cc451dc322a4d7365f9fd6f1b9 SHA512 da48a68029014102e00837a1817d573f293b341716c2ae17fa12f15910a97fcd28ef8b53cb539cc1c029c9916002071485aeddb0e9c6b42aa8d24feeadd5970c
DIST rails-6.0.5.tgz 18572922 BLAKE2B cc7f3669f5d501031ea5bfcef24db89040dc447923abe255b4ae504c07c648414a19a5d2c7ecb513cb96cf601440caeb2462c37fdae61770cef60ce5708abcb4 SHA512 5f262f65de2e3057b92fdb95bef28ea8c4c44e5ca27f4065bb4946a760b3f97fde10f9a303ccf1fdbf833f1e26db5cde722183f41672614203c4b08aef6780ed
DIST rails-6.1.5.1.tgz 10993257 BLAKE2B 90146d33fcad068a09bc61c09417514f2ccc18c51043c63672397eb6980a97c9c0c4e6b0679393c3d8ded690ab44ea53b7abd49817f46ca9f8ab3472dec2f3c3 SHA512 8061f2103ad9266f06f902cf7f05b3f94b05d9b454d314d7a7febea2e5e464c5f33d14f48a2a098e7e666a6dc8cd5c5dae4cf4fb669eca28303a4fb5e6832039
DIST rails-6.1.6.tgz 10993299 BLAKE2B 98a80cbefc1aafba68a22b60d3df6b81ab1e8247a75a07131aeed97ae621ea45b22918482537255547b68a5fc6b002f551b8b94492da3b1e6e24389a109e245c SHA512 04c578f6d8bdcd72691c8d4e51136424f2241a374cdfad1c3c2b436a4f5fde1955a600bcb98c6f416e22e1e561cd50f9ca5f5075deff94f258f8682dc9b00c1c
diff --git a/dev-ruby/activesupport/activesupport-6.0.4.1.ebuild b/dev-ruby/activesupport/activesupport-6.0.4.1.ebuild
deleted file mode 100644
index aa8ba7a98a98..000000000000
--- a/dev-ruby/activesupport/activesupport-6.0.4.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/concurrent-ruby-1.0.2:1
- dev-ruby/i18n:1
- >=dev-ruby/tzinfo-1.1:1
- >=dev-ruby/minitest-5.1:5
- >=dev-ruby/zeitwerk-2.2:2
-"
-
-# memcache-client, nokogiri, builder, and redis are not strictly needed,
-# but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/dalli-2.2.1
- >=dev-ruby/nokogiri-1.4.5
- >=dev-ruby/builder-3.1.0
- >=dev-ruby/listen-3.0.5:3
- dev-ruby/rack
- dev-ruby/mocha
- )"
-
-all_ruby_prepare() {
- # Set the secure permissions that tests expect.
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|redis\|sqlite\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' \
- -e 's/gemspec/gemspec path: "activesupport"/' \
- -e '5igem "builder"; gem "rack"' ../Gemfile || die
- rm ../Gemfile.lock || die
- sed -i -e '1igem "tzinfo", "~> 1.1"' test/abstract_unit.rb || die
-
- # Avoid test that depends on timezone
- sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
-
- # Avoid tests that seem to trigger race conditions.
- rm -f test/evented_file_update_checker_test.rb || die
-
- # Avoid test that generates filename that is too long
- sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
-
- # Avoid tests requiring a live redis running
- rm -f test/cache/stores/redis_cache_store_test.rb || die
- sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
- sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
-}
diff --git a/dev-ruby/activesupport/activesupport-6.0.4.8.ebuild b/dev-ruby/activesupport/activesupport-6.0.4.8.ebuild
deleted file mode 100644
index 8a635120c3c3..000000000000
--- a/dev-ruby/activesupport/activesupport-6.0.4.8.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/concurrent-ruby-1.0.2:1
- dev-ruby/i18n:1
- >=dev-ruby/tzinfo-1.1:1
- >=dev-ruby/minitest-5.1:5
- >=dev-ruby/zeitwerk-2.2:2
-"
-
-# memcache-client, nokogiri, builder, and redis are not strictly needed,
-# but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/dalli-2.2.1
- >=dev-ruby/nokogiri-1.4.5
- >=dev-ruby/builder-3.1.0
- >=dev-ruby/listen-3.0.5:3
- dev-ruby/rack
- dev-ruby/mocha
- )"
-
-all_ruby_prepare() {
- # Set the secure permissions that tests expect.
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|redis\|sqlite\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' \
- -e 's/gemspec/gemspec path: "activesupport"/' \
- -e '5igem "builder"; gem "rack"' ../Gemfile || die
- rm ../Gemfile.lock || die
- sed -i -e '1igem "tzinfo", "~> 1.1"; gem "psych", "~> 3.0"' test/abstract_unit.rb || die
-
- # Avoid test that depends on timezone
- sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
-
- # Avoid tests that seem to trigger race conditions.
- rm -f test/evented_file_update_checker_test.rb || die
-
- # Avoid test that generates filename that is too long
- sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
-
- # Avoid tests requiring a live redis running
- rm -f test/cache/stores/redis_cache_store_test.rb || die
- sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
- sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
-}