summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/curb/Manifest1
-rw-r--r--dev-ruby/curb/curb-0.9.11-r1.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/curb/Manifest b/dev-ruby/curb/Manifest
index 227c66d9ebd4..e8c285d3a555 100644
--- a/dev-ruby/curb/Manifest
+++ b/dev-ruby/curb/Manifest
@@ -1,3 +1,2 @@
-DIST curb-0.9.11.gem 88576 BLAKE2B 1656a17070151ddd1bd63c3e23885d36d8e2b133b19e00347892363a9a20c88baa10932ceb5273733b18847d8d19dc403aa4b7f36fbd80c8dde126ae46743796 SHA512 000ee2054a5866de09042dfc5894330900e401aa94a0fe8bb133fe9c661f7899992adff0585e5ed3725d3564cd9819d76653655f3539faaa61ca6acabe3a8602
DIST curb-1.0.1.gem 90624 BLAKE2B b54404e0ea81ccb2ea03e262abce247ca4e0db1a5208cfecd57a6c0e423c36b282cdaef7db9bd3fe70d3fdb8cfa60c6085be04ff78daac71e83b63fe25bfef06 SHA512 78eeef1b3a778c64517243a25ff82889cb4703589d27f08cff6e84d39a806610a80bb749c51ddba93a82e02a18797978b55ebc4643948caa8900e76d343f4bc6
DIST curb-1.0.3.gem 91648 BLAKE2B 8f819a5411c92e353cee4e1ef87c65bed67783606fcfe238a736ca5110b790d942e1cce6079508b854ab8b22e0079e8240e3d417f9e9ec6c2bef39878321ab55 SHA512 6273acd74121e3a4e42f7cb89eff4bad9511c7cafdf5e046773ec988c816003531877f6e5e756fab73296cedfa4599693014b6b65e9a9001a6e3c4875f53b73e
diff --git a/dev-ruby/curb/curb-0.9.11-r1.ebuild b/dev-ruby/curb/curb-0.9.11-r1.ebuild
deleted file mode 100644
index 884ae6906585..000000000000
--- a/dev-ruby/curb/curb-0.9.11-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl] test? ( net-misc/curl )"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
- # fix tests when localhost is also ::1
- sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
- # avoid tests making outside network connections
- rm tests/bug_postfields_crash.rb || die
- sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
- -i tests/tc_curl_easy.rb || die
- sed -e '/test_connection_keepalive/aomit "network connection needed"' \
- -i tests/tc_curl_multi.rb || die
-
- # Fix test that expects wrong output
- sed -i -e 's/200 OK /200 OK/' tests/tc_curl_easy.rb || die
-
- # avoid failing tests where failure condition seems weird, no
- # upstream travis so not clear if the test is indeed broken.
- sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
-
- # avoid test requiring ntlm support on curl which is no longer available in gentoo
- sed -i -e '/test_username_password/aomit "ntlm support in curl needed"' -i tests/tc_curl_easy.rb || die
-}