summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/nio4r/Manifest1
-rw-r--r--dev-ruby/nio4r/nio4r-2.5.9.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/nio4r/Manifest b/dev-ruby/nio4r/Manifest
index 80d05987f8c6..ee049c38ccdd 100644
--- a/dev-ruby/nio4r/Manifest
+++ b/dev-ruby/nio4r/Manifest
@@ -1 +1,2 @@
DIST nio4r-2.5.8.gem 121856 BLAKE2B be79548761f52abab632b8e4660ab8557946079a51fe7f30c346f4f656ed2f8d0c8f2f463ed76a89bd4278bdfc0a0646ff2b8e0a815f97750836cb0bb250b9ef SHA512 3942403147882380b86f42c54a6d4e92c4e85dd3c0b5b9f473a05fcf98c041853e21d11d0481d1973342b5a4bfb59e02cfd523a44e9e45c3740627a45f7f99c7
+DIST nio4r-2.5.9.gem 122368 BLAKE2B 4238e2963604539207e1adc7ee78430e4f501ea8b71d807ee4f3c44322d16612779777f11b76313aaad6d252321435854f5b4905f83a2fe03c9d71be20b7a718 SHA512 d1c52896f186d19eb089a94d74ccadb427e64c204af149aa83a5a4dda3f0edd1bd2bae94afd21fcd58e3c2b9e2c17278a18717c0905de80e45540d13eeefd9e5
diff --git a/dev-ruby/nio4r/nio4r-2.5.9.ebuild b/dev-ruby/nio4r/nio4r-2.5.9.ebuild
new file mode 100644
index 000000000000..a3db5042c074
--- /dev/null
+++ b/dev-ruby/nio4r/nio4r-2.5.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/nio4r/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="A high performance selector API for monitoring IO objects"
+HOMEPAGE="https://github.com/socketry/nio4r"
+
+LICENSE="MIT || ( BSD GPL-2 )"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Note that nio4r bundles a patched copy of libev, and without these
+# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
+ sed -e '/extension/ s:^:#:' -i Rakefile || die
+}