summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-net-ldap/Manifest2
-rw-r--r--dev-ruby/ruby-net-ldap/ruby-net-ldap-0.7.0.ebuild36
-rw-r--r--dev-ruby/ruby-net-ldap/ruby-net-ldap-0.8.0.ebuild38
3 files changed, 0 insertions, 76 deletions
diff --git a/dev-ruby/ruby-net-ldap/Manifest b/dev-ruby/ruby-net-ldap/Manifest
index 243c414fe014..6ea6b83b0892 100644
--- a/dev-ruby/ruby-net-ldap/Manifest
+++ b/dev-ruby/ruby-net-ldap/Manifest
@@ -1,3 +1 @@
DIST net-ldap-0.11.gem 87040 SHA256 fc5487b0c81cbf2beaede0e6c07af036559deb4ab6df185f61ac16562949d8f5 SHA512 8894fac34df186f03b879e707504ce8952030d38d88e902c8a98f195503765f7780771f26775606ff84a7940cd3b1a8193e028f85d05130940d583c222b4cc1f WHIRLPOOL 67d40f4ca3cb640aeb4a315ab2df44256357a6528c9fa3c69be20e1c2a26f1672c7a2c15afb5111f731dd8f0613000b1f6a9c2624230b62ebd67f64dab6f8ce0
-DIST net-ldap-0.7.0.gem 70656 SHA256 d39d341c992abb7273d8b83cbe32a38e69fdeb4eab684dbd2db1232e4065a4b4 SHA512 71000b05bcf7db8a3c40f6311e16385f2569df12c5b193c454dc2ebd043af0183d650626d8805c0e58e59aa842091da1fba37e35cdb58789279ef5b93ad13e7f WHIRLPOOL 6fbbe9a6ffe1832db61d2eb5cacba4675be9cf9bb7dc9d7102e3c04f244dc7572e2a19d96c62b5e6c77b64467d6efe0e76ad9fcc74837b2404387f2ea8c5ea94
-DIST net-ldap-0.8.0.gem 72704 SHA256 e1b7f21b58a4c2ff6f2c3361f584342017f46d4a965f377f192b4cd8855b0242 SHA512 3083a9bb61a048213d524d9795ac61b38d07abd4788b5504b9d642062f9fcf947120c98e10a76d8e3be0dc91b680bae50b056bd9fcd75cdb4a1af2e907953cf9 WHIRLPOOL e6767bc2985faa6262743d9a6273abe2d693c4d12b21fb5dcc256a49634b059fc2bf831a21ce37128158ff18045e8630790eea2bbda8106dca262b392533ddfa
diff --git a/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.7.0.ebuild b/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.7.0.ebuild
deleted file mode 100644
index 5981aa2faf64..000000000000
--- a/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.7.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-# jruby: requires ruby 1.9 compatibility
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_TEST="test spec"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc History.rdoc README.rdoc"
-
-RUBY_FAKEGEM_NAME="net-ldap"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Pure ruby LDAP client implementation"
-HOMEPAGE="https://github.com/ruby-ldap/ruby-net-ldap"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="test"
-
-ruby_add_bdepend "test? ( >=dev-ruby/flexmock-1.3.0
- >=dev-ruby/metaid-1
- dev-ruby/test-unit:2
- dev-ruby/rspec:2 )"
-
-all_ruby_prepare() {
- sed -i -e '1igem "test-unit"' test/common.rb || die
-
- # Avoid an integration spec that hangs due to setting up pipes and
- # intercepting openssl connect calls.
- rm spec/integration/ssl_ber_spec.rb || die
-}
diff --git a/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.8.0.ebuild b/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.8.0.ebuild
deleted file mode 100644
index db2ed66dd636..000000000000
--- a/dev-ruby/ruby-net-ldap/ruby-net-ldap-0.8.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-# jruby: requires ruby 1.9 compatibility
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_TEST="test spec"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="Contributors.rdoc History.rdoc README.rdoc"
-
-RUBY_FAKEGEM_NAME="net-ldap"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Pure ruby LDAP client implementation"
-HOMEPAGE="https://github.com/ruby-ldap/ruby-net-ldap"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="test"
-
-ruby_add_bdepend "test? ( >=dev-ruby/flexmock-1.3.0
- >=dev-ruby/metaid-1
- dev-ruby/test-unit:2
- dev-ruby/rspec:2 )"
-
-all_ruby_prepare() {
- sed -i -e '1igem "test-unit"' test/common.rb || die
-
- # Fix Specs until RSpec:3 is in tree
- sed -i -e 's/truthy/true/' spec/unit/ldap_spec.rb || die
- # Avoid an integration spec that hangs due to setting up pipes and
- # intercepting openssl connect calls.
- rm spec/integration/ssl_ber_spec.rb || die
-}