summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bson/Manifest1
-rw-r--r--dev-ruby/bson/bson-4.15.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/bson/Manifest b/dev-ruby/bson/Manifest
index 698796f94052..5bb4e02b81b4 100644
--- a/dev-ruby/bson/Manifest
+++ b/dev-ruby/bson/Manifest
@@ -1 +1,2 @@
DIST bson-4.12.0.tar.gz 161250 BLAKE2B 060c33e4192ca433287a007351e13a3de187782675d56b0b90d5dfbf4546821f483348caaab1afa0cb715b20be53028a486f9b18ee8405afc4eeebcfc91c2b53 SHA512 b91619473ba8d4f10fa2a104e26f70d49991e164dd3dc72335bf53f39be6c30dff853cae0185285bc41985ec05717a074992e40ae9b6520d09c0aeb9e0b6992d
+DIST bson-4.15.0.gem 163328 BLAKE2B 21c28ee610a2e067c528e163ac4caec0e76d0ec1a73c8c89a2c455887da54aa0dfaa7ed840736013d87766c5cd4f23dc82b4c6474b0463a32b30575b28c5b898 SHA512 954dd419ab94dfde87d8902745885184505d74333fc71608f64544ca52f728782ea6fc3233718749c110c31ee14802ff240caa8ac4c170369d4adcf45557e79d
diff --git a/dev-ruby/bson/bson-4.15.0.ebuild b/dev-ruby/bson/bson-4.15.0.ebuild
new file mode 100644
index 000000000000..2b68221eb2e7
--- /dev/null
+++ b/dev-ruby/bson/bson-4.15.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_EXTENSIONS=(ext/bson/extconf.rb)
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="https://www.mongodb.org/"
+# We prefer rubygems if we can anyway, but note that rubygems has test sources we need,
+# but github *doesn't* (other way around to usual!)
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+ruby_add_rdepend "dev-ruby/json"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}