summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bcat/bcat-0.6.2-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ruby/bcat/bcat-0.6.2-r2.ebuild b/dev-ruby/bcat/bcat-0.6.2-r2.ebuild
index ecf1f4861a11..17d94f838963 100644
--- a/dev-ruby/bcat/bcat-0.6.2-r2.ebuild
+++ b/dev-ruby/bcat/bcat-0.6.2-r2.ebuild
@@ -20,7 +20,8 @@ IUSE=""
# Collides on /usr/bin/bcat, bug 418301
RDEPEND="${RDEPEND} !!<app-accessibility/speech-tools-2.1-r3"
-ruby_add_bdepend "doc? ( app-text/ronn )"
+ruby_add_bdepend "doc? ( app-text/ronn )
+ test? ( dev-ruby/test-unit:2 )"
ruby_add_rdepend "dev-ruby/rack:*"
@@ -32,7 +33,7 @@ each_ruby_test() {
# The Rakefile uses weird trickery with load path that causes gems
# not to be found. Run tests directly instead and do the trickery
# here to support popen calls for the bins in this package.
- RUBY=${RUBY} RUBYLIB=lib:${RUBYLIB} PATH=bin:${PATH} ${RUBY} -S testrb test/test_*.rb || die
+ RUBY=${RUBY} RUBYLIB=lib:${RUBYLIB} PATH=bin:${PATH} ${RUBY} -S testrb-2 test/test_*.rb || die
}
all_ruby_install() {