summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bson/Manifest2
-rw-r--r--dev-ruby/bson/bson-4.10.0.ebuild43
-rw-r--r--dev-ruby/bson/bson-4.9.4.ebuild43
3 files changed, 0 insertions, 88 deletions
diff --git a/dev-ruby/bson/Manifest b/dev-ruby/bson/Manifest
index 08463c3c011a..698796f94052 100644
--- a/dev-ruby/bson/Manifest
+++ b/dev-ruby/bson/Manifest
@@ -1,3 +1 @@
-DIST bson-4.10.0.tar.gz 158673 BLAKE2B 64a2d608a7b5c048a646e15839be9a77b1203067b018b4cd25174a38c71aa9c7ccc8f95525d1656c76f725ca5b4162e2ce408603a97bbeb51798d4ac0f316bf7 SHA512 8ba561f602e81260ec929271d1275a8393c212948b737b3662ba36e1af0ca9f48904e5497d359ed49b323875b54fac4edf6ed2afdde2505aff7e702192d78f5d
DIST bson-4.12.0.tar.gz 161250 BLAKE2B 060c33e4192ca433287a007351e13a3de187782675d56b0b90d5dfbf4546821f483348caaab1afa0cb715b20be53028a486f9b18ee8405afc4eeebcfc91c2b53 SHA512 b91619473ba8d4f10fa2a104e26f70d49991e164dd3dc72335bf53f39be6c30dff853cae0185285bc41985ec05717a074992e40ae9b6520d09c0aeb9e0b6992d
-DIST bson-4.9.4.tar.gz 157187 BLAKE2B 58bc8293b53f19fb1f02a33b42845c935046c745222ac2474b055945e3d15dfee2be17dffc00faec976419ab51d6597414884520cb8de5a91470ea485b805b9d SHA512 0e1c2c14782d321df5056439dd9f2b2cfd61daa572a4921acb3d8afcf6c50ab679f4c06c82b8d40c0997876b9599cf609ddd77bf80c005028ad711f57d0a502c
diff --git a/dev-ruby/bson/bson-4.10.0.ebuild b/dev-ruby/bson/bson-4.10.0.ebuild
deleted file mode 100644
index 197700a3e462..000000000000
--- a/dev-ruby/bson/bson-4.10.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="mongodb"
-GITHUB_PROJECT="bson-ruby"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
-HOMEPAGE="https://www.mongodb.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="bson-ruby-${PV}"
-
-LICENSE="APSL-2"
-SLOT="4"
-KEYWORDS="~amd64"
-IUSE="test doc"
-
-all_ruby_prepare() {
- # Remove bundler support
- sed -i -e '/bundler/I s:^:#:' Rakefile || die
-
- # Remove project-specific rspec options
- rm .rspec || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/bson/*$(get_modname) lib/ || die
-}
diff --git a/dev-ruby/bson/bson-4.9.4.ebuild b/dev-ruby/bson/bson-4.9.4.ebuild
deleted file mode 100644
index 197700a3e462..000000000000
--- a/dev-ruby/bson/bson-4.9.4.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="mongodb"
-GITHUB_PROJECT="bson-ruby"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
-HOMEPAGE="https://www.mongodb.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="bson-ruby-${PV}"
-
-LICENSE="APSL-2"
-SLOT="4"
-KEYWORDS="~amd64"
-IUSE="test doc"
-
-all_ruby_prepare() {
- # Remove bundler support
- sed -i -e '/bundler/I s:^:#:' Rakefile || die
-
- # Remove project-specific rspec options
- rm .rspec || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/bson/*$(get_modname) lib/ || die
-}