summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rdoc/Manifest1
-rw-r--r--dev-ruby/rdoc/rdoc-6.6.2.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-ruby/rdoc/Manifest b/dev-ruby/rdoc/Manifest
index 4b64877679f8..efe59476844a 100644
--- a/dev-ruby/rdoc/Manifest
+++ b/dev-ruby/rdoc/Manifest
@@ -1,3 +1,4 @@
DIST rdoc-6.5.0.tar.gz 762645 BLAKE2B cecade491f0d18b2c50ec710cb27a28b6cb946f321503e0508e8d4802e93033a78867346eb1d68ca56884ea0d68d51d6fdb92eb61fa63034a01332e8b572dbcf SHA512 10382e66ca778f85f236614fe071b2b0d598065d3aab8f5a89cb0839da7713b5e16a66e3f7a2bff2e2125d26a42f088a86c6d339dc36479a943bb7023c1cad0c
DIST rdoc-6.6.0.tar.gz 764785 BLAKE2B 85bd4b4ece07ae95c9afb6521ba42c1e016f75ef439c71512024ccf2f0ad47f603944aee1aeb28c76c74d59352ae673825c7d7f6bfe46b2ad3e2bafe406feb68 SHA512 fb4c58bb19652a090f45c85fec47be52e2474854ab9ae6705e9a3f6b2ac3381af4aca89b8a39ee5906bab6ff6c63a384d4a12dc6aa19024cc335df18cc92aab7
DIST rdoc-6.6.1.tar.gz 766276 BLAKE2B 480f26688dfa03ac60278b66934f599a2f695787c9c1394b5ea596977c5dc94699429c921cb98fa0faf8aa0b3fd6598441e18cb379886ad152d34eae92206377 SHA512 9baa6fa467c3d4b5dea34a199ca697124bce7ead3bd3a11eb1c28d6a246bf5317331008dde0595baf382a6e05e9bde752008ecb29fe271df1eef3e7875115bd5
+DIST rdoc-6.6.2.tar.gz 765932 BLAKE2B 39bcb0f1af6ee4d53b9011179556d8f1a6b09e20716e60a5d57ca7dcede54797946517e7321004e41d440f26d39e9f3c7c80aaf3b24212ce6a650cddc23d69f3 SHA512 326ead5d4ec5b9328f9feaf3434351911a3dda18d739c8657d9025f7b3387139e1b63ea8fc649870ca474e4a0560ad87cb9e2a13fbbecd240a8aad652d061d42
diff --git a/dev-ruby/rdoc/rdoc-6.6.2.ebuild b/dev-ruby/rdoc/rdoc-6.6.2.ebuild
new file mode 100644
index 000000000000..7ea9b73b0177
--- /dev/null
+++ b/dev-ruby/rdoc/rdoc-6.6.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc RI.rdoc TODO.rdoc"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rdoc.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An extended version of the RDoc library from Ruby 1.8"
+HOMEPAGE="https://github.com/ruby/rdoc/"
+SRC_URI="https://github.com/ruby/rdoc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 Ruby-BSD )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND+=">=app-eselect/eselect-ruby-20181225"
+
+ruby_add_rdepend "
+ >=dev-ruby/psych-4.0.0
+"
+
+ruby_add_bdepend "
+ >=dev-ruby/kpeg-1.1.0-r1
+ >dev-ruby/racc-1.4.10
+ dev-ruby/rake
+ test? (
+ dev-ruby/bundler
+ >=dev-ruby/minitest-5.8:5
+ )"
+
+all_ruby_prepare() {
+ # Other packages also have use for a nonexistent directory, bug 321059
+ sed -i -e 's#/nonexistent#/nonexistent_rdoc_tests#g' test/rdoc/test_rdoc*.rb || die
+
+ # Avoid unneeded dependency on bundler, bug 603696
+ sed -i -e '/bundler/ s:^:#:' \
+ -e 's/Bundler::GemHelper.gemspec.full_name/"rdoc"/' \
+ -e '/rubocop\/rake/ s:^:#:' \
+ -e '/RuboCop/,/end/ s:^:#:' Rakefile || die
+
+ # Skip rubygems tests since the rubygems test case code is no longer installed by rubygems.
+ sed -i -e '/^task/ s/, :rubygems_test//' Rakefile || die
+
+ # Remove test that is depending on the locale, which we can't garantuee.
+ sed -i -e '/def test_encode_with/,/^ end/ s:^:#:' test/rdoc/test_rdoc_options.rb || die
+
+ # Remove test depending on FEATURES=userpriv, bug 361959
+ sed -i -e '/def test_check_files/,/^ end/ s:^:#:' test/rdoc/test_rdoc_options.rb || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ ruby -S exe/rdoc --force-output || die
+ rm -f doc/js/*.gz || die
+ fi
+}
+
+each_ruby_compile() {
+ LANG=C.UTF-8 ${RUBY} -S rake generate || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for bin in rdoc ri; do
+ ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
+
+ for version in $(ruby_get_use_implementations); do
+ version=`echo ${version} | cut -c 5-`
+ if use ruby_targets_ruby${version}; then
+ ruby_fakegem_binwrapper $bin /usr/bin/${bin}${version}
+ sed -i -e "1s/env ruby/ruby${version}/" \
+ "${ED}/usr/bin/${bin}${version}" || die
+ fi
+ done
+ done
+}
+
+pkg_postinst() {
+ if [[ ! -n $(readlink "${ROOT}"/usr/bin/rdoc) ]] ; then
+ eselect ruby set $(eselect --brief --colour=no ruby show | head -n1)
+ fi
+}