summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/bytestructures/bytestructures-2.0.1.ebuild')
-rw-r--r--dev-scheme/bytestructures/bytestructures-2.0.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-scheme/bytestructures/bytestructures-2.0.1.ebuild b/dev-scheme/bytestructures/bytestructures-2.0.1.ebuild
index 165c1a44eda8..3412c6595c4b 100644
--- a/dev-scheme/bytestructures/bytestructures-2.0.1.ebuild
+++ b/dev-scheme/bytestructures/bytestructures-2.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,6 @@ S="${WORKDIR}/scheme-${PN}-${PV}"
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="strip"
RDEPEND=">=dev-scheme/guile-2.0.0:="
DEPEND="${RDEPEND}"
@@ -29,3 +28,11 @@ src_prepare() {
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}
+
+src_install() {
+ default
+
+ # Workaround llvm-strip problem of mangling guile ELF debug
+ # sections: https://bugs.gentoo.org/905898
+ dostrip -x "/usr/$(get_libdir)/guile"
+}