summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/iwidgets/iwidgets-4.1.1.ebuild')
-rw-r--r--dev-tcltk/iwidgets/iwidgets-4.1.1.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-tcltk/iwidgets/iwidgets-4.1.1.ebuild b/dev-tcltk/iwidgets/iwidgets-4.1.1.ebuild
index 5c4d8362e2ed..728e7f8d1756 100644
--- a/dev-tcltk/iwidgets/iwidgets-4.1.1.ebuild
+++ b/dev-tcltk/iwidgets/iwidgets-4.1.1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit multilib
+inherit virtualx multilib
BASE_URI_ITCLTK="mirror://sourceforge/incrtcl/%5BIncr%20Tcl_Tk%5D-4-source"
-ITCL_VER=4.0.3
-ITK_VER=4.0.1
+ITCL_VER=4.1.1
+ITK_VER=4.1.0
DESCRIPTION="Widget collection for incrTcl/incrTk"
HOMEPAGE="http://incrtcl.sourceforge.net/itcl/"
@@ -26,19 +26,16 @@ DEPEND="
>=dev-tcltk/itk-${ITK_VER}"
RDEPEND="${DEPEND}"
-RESTRICT="test"
-
src_prepare() {
default
sed \
-e "/^\(LIB\|SCRIPT\)_INSTALL_DIR =/s|lib|$(get_libdir)|" \
-i Makefile.in || die
- sed -i \
- -e "/require/s:Itk:itk:" \
- iwidgets.tcl.in
# Bug 115470
rm doc/panedwindow.n
+
+ rm tests/hierarchy.test || die
}
src_configure() {
@@ -54,6 +51,10 @@ src_compile() {
:
}
+src_test() {
+ virtx default
+}
+
src_install() {
default