summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tcllib/tcllib-1.19.ebuild')
-rw-r--r--dev-tcltk/tcllib/tcllib-1.19.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-tcltk/tcllib/tcllib-1.19.ebuild b/dev-tcltk/tcllib/tcllib-1.19.ebuild
new file mode 100644
index 000000000000..0cda19041683
--- /dev/null
+++ b/dev-tcltk/tcllib/tcllib-1.19.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit virtualx
+
+DESCRIPTION="Tcl Standard Library"
+HOMEPAGE="http://www.tcl.tk/software/tcllib/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ dev-tcltk/tdom
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ ChangeLog DESCRIPTION.txt README-1.19.txt README.developer
+ devdoc/critcl-tcllib.txt devdoc/dirlayout_install.txt
+ devdoc/indexing.txt devdoc/installation.txt
+)
+HTML_DOCS=( devdoc/devguide.html devdoc/releaseguide.html )
+
+src_test() {
+ USER= virtx emake test_batch
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ for f in $(find examples -type f); do
+ docinto $(dirname $f)
+ dodoc $f
+ done
+ fi
+}