summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclxml/tclxml-3.3.1.ebuild')
-rw-r--r--dev-tcltk/tclxml/tclxml-3.3.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-tcltk/tclxml/tclxml-3.3.1.ebuild b/dev-tcltk/tclxml/tclxml-3.3.1.ebuild
new file mode 100644
index 000000000000..21c1b65eadf8
--- /dev/null
+++ b/dev-tcltk/tclxml/tclxml-3.3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYPN=TclXML
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Pure Tcl implementation of an XML parser"
+HOMEPAGE="https://github.com/flightaware/TclXML"
+SRC_URI="https://github.com/flightaware/TclXML/archive/refs/tags/v${PV}.tar.gz
+ -> ${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="debug threads"
+
+DEPEND="
+ >=dev-lang/tcl-8.2:0
+ >=dev-libs/libxml2-2.6.9
+ dev-libs/libxslt
+ >=dev-tcltk/tcllib-1.2
+ dev-libs/expat"
+# test? ( dev-tcltk/tclparser )
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-fix-implicit-declarations.patch
+)
+
+S="${WORKDIR}"/${MYP}
+
+src_configure() {
+ local myconf=""
+
+ use threads && myconf="${myconf} --enable-threads"
+
+ econf ${myconf} \
+ --with-xml2-config="${EPREFIX}"/usr/bin/xml2-config \
+ --with-xslt-config="${EPREFIX}"/usr/bin/xslt-config \
+ --with-tclinclude="${EPREFIX}"/usr/include \
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable amd64 64bit) \
+ $(use_enable debug symbols)
+}