summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/togl/togl-2.0-r3.ebuild46
-rw-r--r--dev-tcltk/togl/togl-2.0-r4.ebuild6
2 files changed, 5 insertions, 47 deletions
diff --git a/dev-tcltk/togl/togl-2.0-r3.ebuild b/dev-tcltk/togl/togl-2.0-r3.ebuild
deleted file mode 100644
index 017804394aa5..000000000000
--- a/dev-tcltk/togl/togl-2.0-r3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P=Togl${PV}
-
-DESCRIPTION="A Tk widget for OpenGL rendering"
-HOMEPAGE="http://togl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-IUSE="debug +threads"
-
-RDEPEND="
- dev-lang/tk:*
- media-libs/mesa[X]
- x11-libs/libXmu"
-DEPEND="${RDEPEND}"
-
-# tests directory is missing
-RESTRICT="test"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- default
- sed \
- -e 's:-fomit-frame-pointer::g' \
- -e 's:-O2::g' \
- -e 's:-pipe::g' \
- -i configure || die
-}
-
-src_configure() {
- econf \
- $(use_enable debug symbols) \
- $(use_enable threads)
-}
-
-src_install() {
- HTML_DOCS=( doc/* )
- default
-}
diff --git a/dev-tcltk/togl/togl-2.0-r4.ebuild b/dev-tcltk/togl/togl-2.0-r4.ebuild
index f0fed2a97886..57b3a97fdfbf 100644
--- a/dev-tcltk/togl/togl-2.0-r4.ebuild
+++ b/dev-tcltk/togl/togl-2.0-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,6 +27,10 @@ S=${WORKDIR}/${MY_P}
PATCHES=( "${FILESDIR}"/${P}-clang6.patch )
+QA_CONFIG_IMPL_DECL_SKIP=(
+ stat64 # used to test for Large File Support
+)
+
src_prepare() {
default
sed \