summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/biblatex/biblatex-3.0-r1.ebuild')
-rw-r--r--dev-tex/biblatex/biblatex-3.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-tex/biblatex/biblatex-3.0-r1.ebuild b/dev-tex/biblatex/biblatex-3.0-r1.ebuild
new file mode 100644
index 000000000000..47aae74acd4c
--- /dev/null
+++ b/dev-tex/biblatex/biblatex-3.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="Reimplementation of the bibliographic facilities provided by LaTeX"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/biblatex https://github.com/plk/biblatex/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tds.tgz"
+
+LICENSE="LPPL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-latexextra"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+ insinto "${TEXMF}"
+ doins -r bibtex tex
+
+ dodoc doc/latex/biblatex/{README,RELEASE}
+ use doc && { pushd doc/ ; latex-package_src_doinstall doc ; popd ; }
+ if use examples ; then
+ docinto examples
+ dodoc -r doc/latex/biblatex/examples
+ fi
+}