summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/dot2tex/dot2tex-2.11.3.ebuild')
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3.ebuild24
1 files changed, 19 insertions, 5 deletions
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
index 1e00e0e22341..f35891abaa5e 100644
--- a/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
+++ b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A Graphviz to LaTeX converter"
@@ -20,8 +19,23 @@ DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
RDEPEND="
dev-python/pydot[${PYTHON_USEDEP}]
media-gfx/graphviz"
-DEPEND="${DEPEND}
- doc? ( dev-python/sphinx )"
+DEPEND="${DEPEND}"
+BDEPEND="doc? ( dev-python/sphinx )"
+
+EPYTEST_DESELECT=(
+ # https://github.com/kjellmf/dot2tex/issues/94
+ tests/test_dot2tex.py::MultipleStatements::test_semicolon
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Syntax failures (old-style print)
+ # Looks fixed in master: https://github.com/kjellmf/dot2tex/commit/38aeef9615f90fe347c5c45d514eaf00b116422b
+ rm -r "${S}"/tests/experimental || die
+
+ distutils-r1_python_prepare_all
+}
python_compile_all() {
if use doc ; then