summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/rubber/rubber-1.1_p20090819.ebuild')
-rw-r--r--dev-tex/rubber/rubber-1.1_p20090819.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-tex/rubber/rubber-1.1_p20090819.ebuild b/dev-tex/rubber/rubber-1.1_p20090819.ebuild
new file mode 100644
index 000000000000..9892b139a286
--- /dev/null
+++ b/dev-tex/rubber/rubber-1.1_p20090819.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit distutils
+
+IUSE=""
+
+MY_P=${PN}-${PV/*_p/}
+
+DESCRIPTION="A LaTeX wrapper for automatically building documents"
+HOMEPAGE="http://iml.univ-mrs.fr/~beffara/soft/rubber/"
+SRC_URI="http://iml.univ-mrs.fr/~beffara/soft/rubber/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="virtual/latex-base"
+
+S=${WORKDIR}/${P/_p*/}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ # configure script is not created by GNU autoconf
+ ./configure --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+}
+
+src_compile() {
+ distutils_src_compile
+
+ cd doc
+ emake all || die "emake failed"
+}