summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/tth/Manifest1
-rw-r--r--dev-tex/tth/files/tth-4.16-Fix-build-with-Clang-16.patch19
-rw-r--r--dev-tex/tth/tth-4.16.ebuild40
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-tex/tth/Manifest b/dev-tex/tth/Manifest
index 64b577bdf756..9cf8f8c598ed 100644
--- a/dev-tex/tth/Manifest
+++ b/dev-tex/tth/Manifest
@@ -1 +1,2 @@
DIST tth4.08.tar.gz 1085293 BLAKE2B 260613fb9aa1e2acac5daf69db0ea5d3b6495dcb13f8eb3439a8774cf285fccf009dcdb77e33f265051bc9e9d35dda027212042678302b028efee7e4e1019e32 SHA512 c287cece1219155a5a23684b59f9c88459d7bbe7f029bfd6ca26562fa7a8f38699b4e5ce8a85a5f3544c081b5d1483f9533807b026dc85d130cf2e3eae507c05
+DIST tth_4.16.tgz 337901 BLAKE2B ace16726eec5539e81fbafc356c74ed1cc773457100e509cbb5b92fb8bf29bc82655e7d60c6b7ef0bb8e8e4b741c5613bb48e37b8c878757a6354ba1aa0d9267 SHA512 f4c8cc7a268fe8f235ace42a7345cd91efee90103d30b4c24f493982662c51b3d07f4beb2427e177f50e7615d68e1a26055bf3e287c401a9db81a25e614d9281
diff --git a/dev-tex/tth/files/tth-4.16-Fix-build-with-Clang-16.patch b/dev-tex/tth/files/tth-4.16-Fix-build-with-Clang-16.patch
new file mode 100644
index 000000000000..52dc9a2d21f2
--- /dev/null
+++ b/dev-tex/tth/files/tth-4.16-Fix-build-with-Clang-16.patch
@@ -0,0 +1,19 @@
+From 70244cb4546e6114e08b7bdcf8459daddc9bca8b Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 7 Oct 2022 18:33:03 +0100
+Subject: [PATCH] Fix build with Clang 16
+
+--- a/tthsplit.c
++++ b/tthsplit.c
+@@ -6,9 +6,8 @@ Copyright 1997 I.H.Hutchinson.
+ #define LINELEN 256
+ #include <stdio.h>
+ #include <string.h>
+-main(argc,argv)
+-int argc;
+-char *argv[];
++#include <stdlib.h>
++int main(int argc, char *argv[])
+ {
+ int slen;
+ char *ch,*ch2;
diff --git a/dev-tex/tth/tth-4.16.ebuild b/dev-tex/tth/tth-4.16.ebuild
new file mode 100644
index 000000000000..446703397dd9
--- /dev/null
+++ b/dev-tex/tth/tth-4.16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Translate TEX into HTML"
+HOMEPAGE="http://hutchinson.belmont.ma.us/tth/"
+# mirror://sourceforge/${PN}/${PN}${PV}.tar.gz
+SRC_URI="http://hutchinson.belmont.ma.us/tth/tth-noncom/${PN}_${PV}.tgz"
+S="${WORKDIR}"/${PN}_C
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ media-libs/netpbm
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.16-Fix-build-with-Clang-16.patch
+)
+
+src_compile() {
+ # Upstream support a wide variety of obsolete platforms and
+ # are still active, so no point in patching these, bug #874744.
+ # http://hutchinson.belmont.ma.us/tth/platform.html
+ append-flags -std=gnu89 -Wno-strict-prototypes
+
+ emake tth tthsplit
+}
+
+src_install() {
+ dobin tth latex2gif ps2gif ps2png tthsplit
+ dodoc CHANGES
+ doman tth.1
+}