summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/html2latex/html2latex-1.1-r3.ebuild (renamed from dev-tex/html2latex/html2latex-1.1-r2.ebuild)13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-tex/html2latex/html2latex-1.1-r2.ebuild b/dev-tex/html2latex/html2latex-1.1-r3.ebuild
index 1321a9313436..dd5a18cfc929 100644
--- a/dev-tex/html2latex/html2latex-1.1-r2.ebuild
+++ b/dev-tex/html2latex/html2latex-1.1-r3.ebuild
@@ -19,11 +19,17 @@ DEPEND="dev-perl/HTML-Tree
dev-perl/XML-Simple
imagemagick? ( media-gfx/imagemagick )
libwww? ( dev-perl/libwww-perl )"
+RDEPEND="${DEPEND}"
-src_compile() {
+src_configure() {
# HTML::LaTex
- cd HTML
+ cd HTML || die
perl-module_src_configure
+}
+
+src_compile() {
+ # HTML::LaTex
+ cd HTML || die
perl-module_src_compile
}
@@ -33,8 +39,9 @@ src_install() {
dodoc README TODO
# HTML::LaTex
- cd HTML
+ cd HTML || die
perl-module_src_install
+
# rm unwanted README.win
rm "${ED}"/usr/share/doc/${PF}/README.win.txt || die
}