summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bazel/bazel-3.7.2.ebuild')
-rw-r--r--dev-util/bazel/bazel-3.7.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-util/bazel/bazel-3.7.2.ebuild b/dev-util/bazel/bazel-3.7.2.ebuild
index ac040b43670e..8f687a47d16b 100644
--- a/dev-util/bazel/bazel-3.7.2.ebuild
+++ b/dev-util/bazel/bazel-3.7.2.ebuild
@@ -44,8 +44,9 @@ bazel-get-flags() {
}
pkg_setup() {
- echo ${PATH} | grep -q ccache && \
+ if has ccache ${FEATURES}; then
ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ fi
java-pkg-2_pkg_setup
}
@@ -64,6 +65,8 @@ src_prepare() {
# R: /proc/24939/setgroups
# C: /usr/lib/systemd/systemd
addpredict /proc
+
+ eapply "${FILESDIR}/${PN}-3.2.0-include-limits-for-gcc-11.patch"
}
src_compile() {