summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bcc')
-rw-r--r--dev-util/bcc/Manifest2
-rw-r--r--dev-util/bcc/bcc-0.3.0_p20170913.ebuild51
-rw-r--r--dev-util/bcc/bcc-0.4.0.ebuild51
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-util/bcc/Manifest b/dev-util/bcc/Manifest
index 251c71adfd17..8346a7fbce53 100644
--- a/dev-util/bcc/Manifest
+++ b/dev-util/bcc/Manifest
@@ -1,3 +1 @@
-DIST bcc-0.3.0_p20170913.tar.gz 1736513 BLAKE2B 1ed234f3c74e3cc9f47a26f97a8e296499eecc30442a59a3da7b4a5bdb0d628033f01c9ba038a0f2c2de13dd381a627590d387d0c77361e82c10e0a4f5d145b2 SHA512 8298d98fcadc95a2f5f27e1f656f392634c0940cf6ea03f432135477790e770f58dc3e3e0b434391eff8d4e3df6671c250252a29a7344c6adf7606251daef4dd
-DIST bcc-0.4.0.tar.gz 1752520 BLAKE2B 3fdaafebc0ceadbdc5ab2ce0fc7e154ebe0242adb1fec912f517cbf14065a0e79d21794b47a82c4b29c8a618882f75b0d22a29799387c7c250ec54ac7ec5f89e SHA512 d4bca6ab30ed2d398685a5e142bc55ebd70d29b494ce9fa28d85aceb1843111de8f1c61049712d8be9ab827b65866db07b6be27e82bd243e182b7bbe6fb2014f
DIST bcc-0.5.0.tar.gz 1764775 BLAKE2B e1e059b83846115347f225e968edd2823408c26f4f25a89e26c663147ca9c379222c4f1d97578f7cf981fbbb23307deab408bcb278cb26fde5399afbbceb1e39 SHA512 12de5ef04185dccd0847fc97ae855b386e0c81b545ae497af797667925ebedf97164c17fb99468abae3f87fb3ddfdba5200070f80b3bbcad63c2355497012f0e
diff --git a/dev-util/bcc/bcc-0.3.0_p20170913.ebuild b/dev-util/bcc/bcc-0.3.0_p20170913.ebuild
deleted file mode 100644
index 1aaafa79153e..000000000000
--- a/dev-util/bcc/bcc-0.3.0_p20170913.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit cmake-utils linux-info python-single-r1 python-utils-r1
-
-DESCRIPTION="Tools for BPF-based Linux IO analysis, networking, monitoring, and more"
-HOMEPAGE="https://iovisor.github.io/bcc/"
-EGIT_COMMIT="488c119ee7aa7598c11be876acd6761342874e68"
-SRC_URI="https://github.com/iovisor/bcc/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-RESTRICT="test"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND=">=dev-libs/elfutils-0.166:=
- sys-devel/clang:=
- >=sys-devel/llvm-3.7:=[llvm_targets_BPF(+)]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-S=${WORKDIR}/${PN}-${EGIT_COMMIT#v}
-
-pkg_pretend() {
- local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
- ~BPF_JIT ~BPF_EVENTS"
-
- check_extra_config
-}
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DREVISION=${PV%%_*}
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- python_fix_shebang "${ED}"
-}
diff --git a/dev-util/bcc/bcc-0.4.0.ebuild b/dev-util/bcc/bcc-0.4.0.ebuild
deleted file mode 100644
index 0e8e32826953..000000000000
--- a/dev-util/bcc/bcc-0.4.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit cmake-utils linux-info python-single-r1 python-utils-r1
-
-DESCRIPTION="Tools for BPF-based Linux IO analysis, networking, monitoring, and more"
-HOMEPAGE="https://iovisor.github.io/bcc/"
-EGIT_COMMIT="v${PV}"
-SRC_URI="https://github.com/iovisor/bcc/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-RESTRICT="test"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND=">=dev-libs/elfutils-0.166:=
- sys-devel/clang:=
- >=sys-devel/llvm-3.7:=[llvm_targets_BPF(+)]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-S=${WORKDIR}/${PN}-${EGIT_COMMIT#v}
-
-pkg_pretend() {
- local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
- ~BPF_JIT ~BPF_EVENTS"
-
- check_extra_config
-}
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DREVISION=${PV%%_*}
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- python_fix_shebang "${ED}"
-}