summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bear')
-rw-r--r--dev-util/bear/Manifest2
-rw-r--r--dev-util/bear/bear-3.0.11-r2.ebuild87
-rw-r--r--dev-util/bear/bear-3.0.12-r1.ebuild87
3 files changed, 0 insertions, 176 deletions
diff --git a/dev-util/bear/Manifest b/dev-util/bear/Manifest
index a95b698b433b..5ffec631ff1e 100644
--- a/dev-util/bear/Manifest
+++ b/dev-util/bear/Manifest
@@ -1,4 +1,2 @@
DIST bear-2.4.4.tar.gz 50347 BLAKE2B 73fa332cf97413e55c588f8830806a26c6905299af902c6cf1f39fd576c6261690239c1b502b28b5a2aa24e5ca521c3f1dd58aacd60e00ece4fe1840f5656155 SHA512 4ee3fd5c846149029fe9e4104e2a0d0e318a15215aa80fc5dc376e22ebea510384b02d4d62765495343cab537bacd2b1b0130c00246e081feb4e543761a594e5
-DIST bear-3.0.11.tar.gz 118678 BLAKE2B 209d904a84363a87e566798dcd65ffed96cdbf3d2e753af8dc2706adb995d2999bc112eabb88db28791cbb245c373eb330cf9c20d3d886bb2caeb5c01150e65d SHA512 6d362aede911a8ad35be30638a698579582ca5de770a7c3199bb205046f08f355387099261b8d857188d526ab62024f78e3d06a225734c5f9acca03e5dfea1ec
-DIST bear-3.0.12.tar.gz 118937 BLAKE2B 4ed41693a92583091b8510dd1ade55a3e5c897825205e59d9e9810aa63e5f17c5049b3b3de509665143083d44aeb6d85c63d944041bb36c6b1d842d0308d88f0 SHA512 e45e842793e9f5f2cd6b13a9795c2b6753c2fffd516e4af9f0362644c9d0952a2b0e505a4a9d53e9a1a4aa063d7368c6466367a78fececb70582ec7c4e8d7f10
DIST bear-3.0.13.tar.gz 120488 BLAKE2B 9159858110afc45f4888a294325be8609bdcb78a2421dbb8ae4b5109cbea80a06d907e961c398cf011025d93d8d1cceec640ce12d613fd80d38d8f06532305db SHA512 1c515d5941870b9bc76fa85d02229ace85653c6f985e00a8fa9e2f17ba9079d162d654a17024394819a7ae203167253641a3d7c17c490e49e30fa92d434e6a6e
diff --git a/dev-util/bear/bear-3.0.11-r2.ebuild b/dev-util/bear/bear-3.0.11-r2.ebuild
deleted file mode 100644
index 97791cb96b0b..000000000000
--- a/dev-util/bear/bear-3.0.11-r2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Build EAR generates a compilation database for clang tooling"
-HOMEPAGE="https://github.com/rizsotto/Bear"
-SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-cpp/nlohmann_json-3.7:=
- >=dev-db/sqlite-3.14:=
- >=dev-libs/libfmt-6.2:=
- dev-libs/protobuf:=
- >=dev-libs/spdlog-1.5
- >=net-libs/grpc-1.26:=
-"
-
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.10
- )
-"
-
-BDEPEND="test? (
- $(python_gen_any_dep '
- dev-python/lit[${PYTHON_USEDEP}]
- ')
-)"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Turn off testing before installation
- sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_UNIT_TESTS="$(usex test ON OFF)"
- -DENABLE_FUNC_TESTS="$(usex test ON OFF)"
- )
- cmake_src_configure
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
- ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
- ewarn "Skipping tests"
- elif
- has usersandbox ${FEATURES}; then
- ewarn "\'FEATURES=usersandbox\' detected"
- ewarn "Skipping tests"
- elif
- has network-sandbox ${FEATURES}; then
- ewarn "\'FEATURES=network-sandbox\' detected"
- ewarn "Skipping tests"
- elif
- has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
- ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
- ewarn "and will fail without generic cc symlink"
- ewarn "Skipping tests"
- else
- einfo "test may use optional tools if found: qmake gfortran valgrind"
- # unit tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
- # functional tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
- fi
-}
diff --git a/dev-util/bear/bear-3.0.12-r1.ebuild b/dev-util/bear/bear-3.0.12-r1.ebuild
deleted file mode 100644
index 97791cb96b0b..000000000000
--- a/dev-util/bear/bear-3.0.12-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Build EAR generates a compilation database for clang tooling"
-HOMEPAGE="https://github.com/rizsotto/Bear"
-SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-cpp/nlohmann_json-3.7:=
- >=dev-db/sqlite-3.14:=
- >=dev-libs/libfmt-6.2:=
- dev-libs/protobuf:=
- >=dev-libs/spdlog-1.5
- >=net-libs/grpc-1.26:=
-"
-
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.10
- )
-"
-
-BDEPEND="test? (
- $(python_gen_any_dep '
- dev-python/lit[${PYTHON_USEDEP}]
- ')
-)"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Turn off testing before installation
- sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_UNIT_TESTS="$(usex test ON OFF)"
- -DENABLE_FUNC_TESTS="$(usex test ON OFF)"
- )
- cmake_src_configure
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
- ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
- ewarn "Skipping tests"
- elif
- has usersandbox ${FEATURES}; then
- ewarn "\'FEATURES=usersandbox\' detected"
- ewarn "Skipping tests"
- elif
- has network-sandbox ${FEATURES}; then
- ewarn "\'FEATURES=network-sandbox\' detected"
- ewarn "Skipping tests"
- elif
- has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
- ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
- ewarn "and will fail without generic cc symlink"
- ewarn "Skipping tests"
- else
- einfo "test may use optional tools if found: qmake gfortran valgrind"
- # unit tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
- # functional tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
- fi
-}