summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/beediff/beediff-1.9.ebuild')
-rw-r--r--dev-util/beediff/beediff-1.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/beediff/beediff-1.9.ebuild b/dev-util/beediff/beediff-1.9.ebuild
new file mode 100644
index 000000000000..f4c3df1f9168
--- /dev/null
+++ b/dev-util/beediff/beediff-1.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qt4-r2
+
+DESCRIPTION="A graphical user interface for comparing and merging files"
+HOMEPAGE="http://www.beesoft.pl/index.php?id=beediff"
+SRC_URI="http://www.beesoft.pl/download/${PN}_${PV}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e '/QMAKE_CXXFLAGS/d' \
+ beediff.pro || die
+}
+
+src_install() {
+ dobin ${PN}
+ doicon img/${PN}.png
+ make_desktop_entry ${PN} "Beesoft Differ" ${PN} "Qt;Development;"
+ dodoc ChangeLog.txt
+}