summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bloaty/bloaty-1.1.ebuild')
-rw-r--r--dev-util/bloaty/bloaty-1.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-util/bloaty/bloaty-1.1.ebuild b/dev-util/bloaty/bloaty-1.1.ebuild
deleted file mode 100644
index 227dcc50dcdf..000000000000
--- a/dev-util/bloaty/bloaty-1.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="A size profiler for binaries"
-HOMEPAGE="https://github.com/google/bloaty"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/google/${PN}"
- IUSE="test"
- RESTRICT="!test? ( test )"
-else
- SRC_URI="https://github.com/google/${PN}/releases/download/v${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64"
-fi
-
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="
- dev-libs/capstone:=
- dev-libs/protobuf:=
- dev-libs/re2:=
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DBLOATY_ENABLE_CMAKETARGETS=OFF
- -DBUILD_SHARED_LIBS=OFF
- )
- if [[ ${PV} == 9999 ]]; then
- mycmakeargs+=(
- -DBUILD_TESTING=$(usex test)
- $(usex test -DINSTALL_GTEST=OFF "")
- )
- fi
- cmake_src_configure
-}