summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/buildbot-pkg/buildbot-pkg-3.5.0.ebuild')
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-3.5.0.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-3.5.0.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-3.5.0.ebuild
deleted file mode 100644
index 4d4e95e9196c..000000000000
--- a/dev-util/buildbot-pkg/buildbot-pkg-3.5.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_PV="${PV/_p/.post}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="BuildBot common www build tools for packaging releases"
-HOMEPAGE="https://buildbot.net/
- https://github.com/buildbot/buildbot
- https://pypi.org/project/buildbot-pkg/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
-
-# No real integration tests for this pkg.
-# all tests are related to making releases and final checks for distribution
-RESTRICT="test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-src_prepare() {
- sed -e "/version/s/=.*$/=\"${MY_PV}\",/" -i setup.py || die
- distutils-r1_src_prepare
-}