summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/buildbot-www')
-rw-r--r--dev-util/buildbot-www/Manifest1
-rw-r--r--dev-util/buildbot-www/buildbot-www-3.11.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/Manifest b/dev-util/buildbot-www/Manifest
index 767c84e01c70..853d1c514216 100644
--- a/dev-util/buildbot-www/Manifest
+++ b/dev-util/buildbot-www/Manifest
@@ -1,3 +1,4 @@
DIST buildbot-www-3.11.0.tar.gz 3211644 BLAKE2B 8e217c5e6158abd2d8cab29e83b5d73fef3d032fac9e4b836aeb865f9dcae7a70bb2070d0ba2537fa239ab81b47578c3f3e4f2ff5becc255e3b6cbcf22157e16 SHA512 0813512175b43f13ac5ca6701de8e2d164c5e4d69211812f04af9c3ef47d55f9ac8419b8b5557ab69b5acbed11cc9cbe5d664ff685a2a3e800428fb0f9e0f323
+DIST buildbot-www-3.11.1.tar.gz 3211634 BLAKE2B bb64ae2ad4ac84aee876a9b2ef4e92b8946533e0942abab45b088f1947d107e3404251bcb0e7af473b4539f40985fac559d5bd7596c039a2d8044b6a0a653f6b SHA512 195d69210d19d782e2147df266d0babc78ec11ced15518e993daa7a278ae895444771a323b9bc5543ef685b93013d7b4c2cac5b42304ad46726adc112fe17da2
DIST buildbot-www-3.6.1.tar.gz 3210526 BLAKE2B 6db8be32ee85cab63ad3f92d0e24042ed1ebece3b7be1b67e6f72240f61f3af2c31f1b3b31315db0d7ca18dddab1351eacffb92e762d1f1d68ce414349e52eee SHA512 d2fb3f97412e4a1b21fe7637458dffa8e8e005693ad2275222e908d35551ec64f89a88e696859a09f64b2b5be5fbdb386fbd71324356dbe8c2adc92b1c6b9f01
DIST buildbot-www-3.9.0.tar.gz 3211620 BLAKE2B d5a75845941b456537be50484d341e450f545cf14ccafdc245d4b4d296df154e333d2797f8e5f5dc42c872a83360c675b0e747564cbcc3c182c4c1c0138205fb SHA512 2c88e0f41d5f4de37eecebc43b21f5f741771e0ecaed79865744503b939335f1f1dd426cd2e1cdbcf75a7573aa89ab5913e4c64aa6dea9e13fa19646dd717c0b
diff --git a/dev-util/buildbot-www/buildbot-www-3.11.1.ebuild b/dev-util/buildbot-www/buildbot-www-3.11.1.ebuild
new file mode 100644
index 000000000000..2a01e37f15ca
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-3.11.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-www/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"