summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/catkin')
-rw-r--r--dev-util/catkin/catkin-0.7.1-r1.ebuild (renamed from dev-util/catkin/catkin-0.7.1.ebuild)3
-rw-r--r--dev-util/catkin/catkin-9999.ebuild3
-rw-r--r--dev-util/catkin/files/catkin_prefix_path_util_py.patch16
3 files changed, 20 insertions, 2 deletions
diff --git a/dev-util/catkin/catkin-0.7.1.ebuild b/dev-util/catkin/catkin-0.7.1-r1.ebuild
index ddfc8ba1e712..cf494b1753ee 100644
--- a/dev-util/catkin/catkin-0.7.1.ebuild
+++ b/dev-util/catkin/catkin-0.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -40,6 +40,7 @@ PATCHES=(
"${FILESDIR}/distutils.patch"
"${FILESDIR}/catkin_prefix_path.patch"
"${FILESDIR}/gnuinstalldirs.patch"
+ "${FILESDIR}/catkin_prefix_path_util_py.patch"
)
src_prepare() {
diff --git a/dev-util/catkin/catkin-9999.ebuild b/dev-util/catkin/catkin-9999.ebuild
index ddfc8ba1e712..cf494b1753ee 100644
--- a/dev-util/catkin/catkin-9999.ebuild
+++ b/dev-util/catkin/catkin-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -40,6 +40,7 @@ PATCHES=(
"${FILESDIR}/distutils.patch"
"${FILESDIR}/catkin_prefix_path.patch"
"${FILESDIR}/gnuinstalldirs.patch"
+ "${FILESDIR}/catkin_prefix_path_util_py.patch"
)
src_prepare() {
diff --git a/dev-util/catkin/files/catkin_prefix_path_util_py.patch b/dev-util/catkin/files/catkin_prefix_path_util_py.patch
new file mode 100644
index 000000000000..d97817662e76
--- /dev/null
+++ b/dev-util/catkin/files/catkin_prefix_path_util_py.patch
@@ -0,0 +1,16 @@
+Author: Eric Timmons
+https://bugs.gentoo.org/show_bug.cgi?id=586104
+
+Index: catkin-0.6.16/cmake/templates/_setup_util.py.in
+===================================================================
+--- catkin-0.6.16.orig/cmake/templates/_setup_util.py.in
++++ catkin-0.6.16/cmake/templates/_setup_util.py.in
+@@ -262,7 +262,7 @@
+ sys.exit(1)
+
+ # environment at generation time
+- CMAKE_PREFIX_PATH = '@CMAKE_PREFIX_PATH_AS_IS@'.split(';')
++ CMAKE_PREFIX_PATH = '@CATKIN_PREFIX_PATH@;@CMAKE_PREFIX_PATH_AS_IS@'.split(';')
+ # prepend current workspace if not already part of CPP
+ base_path = os.path.dirname(__file__)
+ if base_path not in CMAKE_PREFIX_PATH: