summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccache/ccache-3.7.9.ebuild')
-rw-r--r--dev-util/ccache/ccache-3.7.9.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-util/ccache/ccache-3.7.9.ebuild b/dev-util/ccache/ccache-3.7.9.ebuild
deleted file mode 100644
index 6a749a059596..000000000000
--- a/dev-util/ccache/ccache-3.7.9.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="fast compiler cache"
-HOMEPAGE="https://ccache.dev/"
-SRC_URI="https://github.com/ccache/ccache/releases/download/v${PV}/ccache-${PV}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="test"
-
-DEPEND="app-arch/xz-utils
- sys-libs/zlib"
-RDEPEND="${DEPEND}
- dev-util/shadowman
- sys-apps/gentoo-functions"
-# clang-specific tests use dev-libs/elfutils to compare objects for equality.
-# Let's pull in the dependency unconditionally.
-DEPEND+="
- test? ( dev-libs/elfutils )"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
-)
-
-src_prepare() {
- default
-
- sed \
- -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
- "${FILESDIR}"/ccache-config-3 > ccache-config || die
-}
-
-src_configure() {
- econf --without-bundled-zlib
-}
-
-src_compile() {
- emake V=1
-}
-
-src_test() {
- emake check V=1
-}
-
-src_install() {
- DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
- default
-
- dobin ccache-config
- insinto /usr/share/shadowman/tools
- newins - ccache <<<"${EPREFIX}/usr/lib/ccache/bin"
-}
-
-pkg_prerm() {
- if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
- eselect compiler-shadow remove ccache
- fi
-}
-
-pkg_postinst() {
- if [[ ${ROOT:-/} == / ]]; then
- eselect compiler-shadow update ccache
- fi
-}