summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/clinfo/clinfo-3.0.21.02.21-r1.ebuild')
-rw-r--r--dev-util/clinfo/clinfo-3.0.21.02.21-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/clinfo/clinfo-3.0.21.02.21-r1.ebuild b/dev-util/clinfo/clinfo-3.0.21.02.21-r1.ebuild
new file mode 100644
index 000000000000..24dcd892d0af
--- /dev/null
+++ b/dev-util/clinfo/clinfo-3.0.21.02.21-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=virtual/opencl-3"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}