summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/clippy')
-rw-r--r--dev-util/clippy/Manifest3
-rw-r--r--dev-util/clippy/clippy-9.0.1.ebuild58
-rw-r--r--dev-util/clippy/clippy-9.0.2.ebuild58
-rw-r--r--dev-util/clippy/clippy-9.0.ebuild58
-rw-r--r--dev-util/clippy/metadata.xml19
5 files changed, 196 insertions, 0 deletions
diff --git a/dev-util/clippy/Manifest b/dev-util/clippy/Manifest
new file mode 100644
index 000000000000..376770103a91
--- /dev/null
+++ b/dev-util/clippy/Manifest
@@ -0,0 +1,3 @@
+DIST frr-9.0.1.tar.gz 10334150 BLAKE2B c5f0d092421cdaea400e669973da3d53d9875871488be3b5e8c2c9afa78bf357a775671756eacb94372c5067a8a1284cb4feb4927988e0f1a42d19239a871f3b SHA512 fa1884529a98c8e5ad2dab7f6f67246844ea34ba4d68e3a907a01d43e0eec9317104107f5f18e4b61c11d2cbb4d20eac1e8aef6e4a2b2e54efcad245ee3fb6b9
+DIST frr-9.0.2.tar.gz 10341186 BLAKE2B e9c32bf48dc0adc7dd6c23ad1a2779065c762dc6e461a3f86d6b7afbef245345dc65b33d9dd5b499d4c4a7fb3b80a4416bdec9b42e7d15f2864d80c088e2ad4f SHA512 2cfd1a63cf073b8767fd67d9992d9a775d856234a532b13699304b6b1f15eb68bf1301f2f4c503b151fd5c8191bff67aeac9c7a4dc4a3ddb06f9a5db081423b9
+DIST frr-9.0.tar.gz 10332694 BLAKE2B 82221df6da189d5e687af4618af71933eb512413126dfb312bfcc663e5fc6f85e29c33da84117f40598452e6033cb24e9cba8d28f00d63fee2bf45a43babef17 SHA512 d3af6c24abbc8745f9646a22c023bd1d0e155776ffd09c9dd0b81b93c383723c9e7dd987319551db85dab5fd45d47cbcbf47a1ae1b6861cd7930bc27f18d2e25
diff --git a/dev-util/clippy/clippy-9.0.1.ebuild b/dev-util/clippy/clippy-9.0.1.ebuild
new file mode 100644
index 000000000000..5c3fda52b99a
--- /dev/null
+++ b/dev-util/clippy/clippy-9.0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="frr-${PV}"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools python-single-r1
+
+DESCRIPTION="Standalone clippy tool built from FRR sources"
+HOMEPAGE="https://frrouting.org/"
+SRC_URI="https://github.com/FRRouting/frr/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/frr-${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# standalone clippy does not have any tests
+# restrict to prevent bug 811753
+RESTRICT="test"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ virtual/libelf:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ mallinfo # check in configure is fallback is needed
+ mallinfo2 # check in configure is fallback is needed
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # bug #884291
+ unset YACC
+ export LEX=flex
+
+ econf --enable-clippy-only
+}
+
+src_install() {
+ # 830087
+ find "lib" -type f -name "clippy" -print0 |
+ xargs -0 file | grep executable | grep ELF | cut -f 1 -d : |
+ xargs -I '{}' dobin '{}' ||
+ die "Failed to install 'lib/clippy'"
+}
diff --git a/dev-util/clippy/clippy-9.0.2.ebuild b/dev-util/clippy/clippy-9.0.2.ebuild
new file mode 100644
index 000000000000..5c9ed4fb9169
--- /dev/null
+++ b/dev-util/clippy/clippy-9.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="frr-${PV}"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools python-single-r1
+
+DESCRIPTION="Standalone clippy tool built from FRR sources"
+HOMEPAGE="https://frrouting.org/"
+SRC_URI="https://github.com/FRRouting/frr/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/frr-${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# standalone clippy does not have any tests
+# restrict to prevent bug 811753
+RESTRICT="test"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ virtual/libelf:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ mallinfo # check in configure is fallback is needed
+ mallinfo2 # check in configure is fallback is needed
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # bug #884291
+ unset YACC
+ export LEX=flex
+
+ econf --enable-clippy-only
+}
+
+src_install() {
+ # 830087
+ find "lib" -type f -name "clippy" -print0 |
+ xargs -0 file | grep executable | grep ELF | cut -f 1 -d : |
+ xargs -I '{}' dobin '{}' ||
+ die "Failed to install 'lib/clippy'"
+}
diff --git a/dev-util/clippy/clippy-9.0.ebuild b/dev-util/clippy/clippy-9.0.ebuild
new file mode 100644
index 000000000000..5c3fda52b99a
--- /dev/null
+++ b/dev-util/clippy/clippy-9.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="frr-${PV}"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools python-single-r1
+
+DESCRIPTION="Standalone clippy tool built from FRR sources"
+HOMEPAGE="https://frrouting.org/"
+SRC_URI="https://github.com/FRRouting/frr/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/frr-${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# standalone clippy does not have any tests
+# restrict to prevent bug 811753
+RESTRICT="test"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ virtual/libelf:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ mallinfo # check in configure is fallback is needed
+ mallinfo2 # check in configure is fallback is needed
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # bug #884291
+ unset YACC
+ export LEX=flex
+
+ econf --enable-clippy-only
+}
+
+src_install() {
+ # 830087
+ find "lib" -type f -name "clippy" -print0 |
+ xargs -0 file | grep executable | grep ELF | cut -f 1 -d : |
+ xargs -I '{}' dobin '{}' ||
+ die "Failed to install 'lib/clippy'"
+}
diff --git a/dev-util/clippy/metadata.xml b/dev-util/clippy/metadata.xml
new file mode 100644
index 000000000000..b19c1cfaa54d
--- /dev/null
+++ b/dev-util/clippy/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <name>Alarig Le Lay</name>
+ <email>alarig@swordarmor.fr</email>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>jaco@uls.co.za</email>
+ <name>Jaco Kroon</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">FRRouting/frr</remote-id>
+ </upstream>
+</pkgmetadata>