summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/Manifest4
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.5.ebuild121
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.6.ebuild123
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.8.ebuild122
-rw-r--r--dev-util/coccinelle/coccinelle-1.1.1-r5.ebuild136
-rw-r--r--dev-util/coccinelle/files/coccinelle-1.1.1-bash-completion.patch19
-rw-r--r--dev-util/coccinelle/files/coccinelle-1.1.1-find-xxdate.patch11
-rw-r--r--dev-util/coccinelle/files/coccinelle-1.1.1-shuffle.patch12
-rw-r--r--dev-util/coccinelle/metadata.xml8
9 files changed, 186 insertions, 370 deletions
diff --git a/dev-util/coccinelle/Manifest b/dev-util/coccinelle/Manifest
index e0e091baed97..55489c38c940 100644
--- a/dev-util/coccinelle/Manifest
+++ b/dev-util/coccinelle/Manifest
@@ -1,3 +1 @@
-DIST coccinelle-1.0.5.tgz 5660596 BLAKE2B 9707e4773d165718b973e004e3359608428d8405d560d7013da66e2b1f0205f003ae0905c02a4f13c9725b39dc94710e5ccbc6b5b11ace66d7e87c3a303363c5 SHA512 0fee450554abc40feac9e745a252c1679f8016c82f04236e642e32e129618a950bb9657f1c447d62543289e95bbd4b1a8b0c6030373025c32a37068f82d30678
-DIST coccinelle-1.0.6.tgz 6684278 BLAKE2B b5b390488e818ce05c364f27782bd1c4dc63657a01c7564764d64faea8ff302c8409bb2ef172ce7ab7c2e00ae1a6f2c3bea76a1148eaf5a977f897d39a9fb23c SHA512 b667762ddf5ad30b126e93572cd8a8b3ffc21a790cd9d6df586e421c5db0a8d049af9587c6e5cb8f7a13f2c090ab2a9cca59ecba69069f9d3fe67b6f75dfe539
-DIST coccinelle-1.0.8.tar.gz 2670961 BLAKE2B 0a11d325f8e39a76111bb9b14afb5dc6c1de07b94fce7904b6be021b17a9346f1b2e09550e6de221280fa9ff57e6e4a41b2e733189e16cc3a460065844015901 SHA512 496b1632c92cc026fbe28f784f56d4cd78f89a8ccd28dc7db1069c0c6b2b239675a10da305e37ed2a03c605668ecd3399aeed522f12ec3fbbf3ca07277ab7bce
+DIST coccinelle-1.1.1.tar.bz2 2118055 BLAKE2B 7efb0c86432c88daa1bce2710acdf2f62b6210c69245b4896ea8c5e39a0b28c538d94deae6ed1544e0ced66b2baa6edf8670f5e02dad40c2d1f5562326ce23e3 SHA512 fcb83203c91dae18122cf95f7db931d2e1576559b74a7a1c664c795437904acdffa005a8b9e732c1d99c8f0ab1c5f529d143eafe79c6397d28c4879848afca45
diff --git a/dev-util/coccinelle/coccinelle-1.0.5.ebuild b/dev-util/coccinelle/coccinelle-1.0.5.ebuild
deleted file mode 100644
index 241294dd2260..000000000000
--- a/dev-util/coccinelle/coccinelle-1.0.5.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common
-
-MY_P="${P/_/-}"
-DESCRIPTION="Program matching and transformation engine"
-HOMEPAGE="http://coccinelle.lip6.fr/"
-SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# ocaml enables ocaml scripting (uses findlib)
-CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
- dev-ml/sexplib:=[ocamlopt(+)?]
- dev-ml/menhir:=[ocamlopt?]
- dev-ml/camlp4:=[ocamlopt?]
- dev-ml/parmap:=[ocamlopt?]
- emacs? ( >=app-editors/emacs-23.1:* )
- ocaml? ( dev-ml/findlib:= )
- pcre? ( dev-ml/pcre-ocaml:=[ocamlopt(+)?] )
- python? ( ${PYTHON_DEPS} )"
-
-RDEPEND="${CDEPEND}
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
-
-# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsextra
- )"
-
-DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
-
-RESTRICT="strip !test? ( test )"
-S=${WORKDIR}/${MY_P}
-
-SITEFILE=50coccinelle-gentoo.el
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- if use python ; then
- # fix python install location
- sed -e "s:\$(LIBDIR)/python:$(python_get_sitedir):" \
- -i Makefile || die
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable python) \
- $(use_enable ocaml) \
- $(use_enable pcre) \
- $(use_enable pcre pcre-syntax) \
- $(use_enable ocamlopt opt)
-}
-
-src_compile() {
- emake depend
-
- if use ocamlopt ; then
- emake all.opt
- else
- emake TARGET_SPATCH=byte-only all-dev
- fi
-
- if use doc ; then
- VARTEXFONTS="${T}"/fonts emake docs
- fi
-
- if use emacs ; then
- elisp-compile editors/emacs/cocci.el || die
- fi
-}
-
-src_test() {
- emake check
- use python && emake pycocci-check
-}
-
-src_install() {
- default
-
- use doc && dodoc docs/manual/*.pdf
- newbashcomp scripts/spatch.bash_completion spatch
-
- if use emacs ; then
- elisp-install ${PN} editors/emacs/*
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-
- if use vim-syntax ; then
- newdoc editors/vim/README README-vim
- rm editors/vim/README || die
- insinto /usr/share/vim/vimfiles
- doins -r editors/vim/*
- fi
-
- use python && python_optimize
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/coccinelle/coccinelle-1.0.6.ebuild b/dev-util/coccinelle/coccinelle-1.0.6.ebuild
deleted file mode 100644
index 55e35ea5d44e..000000000000
--- a/dev-util/coccinelle/coccinelle-1.0.6.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common
-
-MY_P="${P/_/-}"
-DESCRIPTION="Program matching and transformation engine"
-HOMEPAGE="http://coccinelle.lip6.fr/"
-SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# ocaml enables ocaml scripting (uses findlib)
-CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
- dev-ml/sexplib:=[ocamlopt(+)?]
- dev-ml/menhir:=[ocamlopt?]
- dev-ml/camlp4:=[ocamlopt?]
- dev-ml/parmap:=[ocamlopt?]
- emacs? ( >=app-editors/emacs-23.1:* )
- ocaml? ( dev-ml/findlib:= )
- pcre? ( dev-ml/pcre-ocaml:=[ocamlopt(+)?] )
- python? ( ${PYTHON_DEPS} )"
-
-RDEPEND="${CDEPEND}
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
-
-# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsextra
- )"
-
-DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
-
-RESTRICT="strip !test? ( test )"
-S=${WORKDIR}/${MY_P}
-
-SITEFILE=50coccinelle-gentoo.el
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- if use python ; then
- # fix python install location
- sed -e "s:\$(LIBDIR)/python:$(python_get_sitedir):" \
- -i Makefile || die
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable python) \
- $(use_enable ocaml) \
- $(use_enable pcre) \
- $(use_enable pcre pcre-syntax) \
- $(use_enable ocamlopt opt)
-}
-
-src_compile() {
- emake depend
-
- if use ocamlopt ; then
- emake all.opt
- else
- emake TARGET_SPATCH=byte-only all-dev
- fi
-
- if use doc ; then
- VARTEXFONTS="${T}"/fonts emake docs
- fi
-
- if use emacs ; then
- elisp-compile editors/emacs/cocci.el || die
- fi
-}
-
-src_test() {
- emake check
- use python && emake pycocci-check
-}
-
-src_install() {
- default
-
- use doc && dodoc docs/manual/*.pdf
- newbashcomp scripts/spatch.bash_completion spatch
-
- if use emacs ; then
- elisp-install ${PN} editors/emacs/*
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-
- if use vim-syntax ; then
- newdoc editors/vim/README README-vim
- rm editors/vim/README || die
- insinto /usr/share/vim/vimfiles
- doins -r editors/vim/*
- fi
-
- use python && python_optimize
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/coccinelle/coccinelle-1.0.8.ebuild b/dev-util/coccinelle/coccinelle-1.0.8.ebuild
deleted file mode 100644
index ebf1fd10abac..000000000000
--- a/dev-util/coccinelle/coccinelle-1.0.8.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools multilib eutils python-single-r1 bash-completion-r1 elisp-common
-
-DESCRIPTION="Program matching and transformation engine"
-HOMEPAGE="http://coccinelle.lip6.fr/"
-SRC_URI="https://github.com/coccinelle/coccinelle/archive/1.0.8.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# ocaml enables ocaml scripting (uses findlib)
-CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
- dev-ml/sexplib:=[ocamlopt(+)?]
- dev-ml/menhir:=[ocamlopt?]
- dev-ml/camlp4:=[ocamlopt?]
- dev-ml/parmap:=[ocamlopt?]
- emacs? ( >=app-editors/emacs-23.1:* )
- ocaml? ( dev-ml/findlib:= )
- pcre? ( dev-ml/pcre-ocaml:=[ocamlopt(+)?] )
- python? ( ${PYTHON_DEPS} )"
-
-RDEPEND="${CDEPEND}
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
-
-# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsextra
- )"
-
-DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
-
-RESTRICT="strip !test? ( test )"
-
-SITEFILE=50coccinelle-gentoo.el
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- eautoreconf
- if use python ; then
- # fix python install location
- sed -e "s:\$(LIBDIR)/python:$(python_get_sitedir):" \
- -i Makefile || die
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable python) \
- $(use_enable ocaml) \
- $(use_enable pcre) \
- $(use_enable pcre pcre-syntax) \
- $(use_enable ocamlopt opt)
-}
-
-src_compile() {
- emake -j1
-
- if use ocamlopt ; then
- emake all.opt
- else
- emake TARGET_SPATCH=byte-only all-dev
- fi
-
- if use doc ; then
- VARTEXFONTS="${T}"/fonts emake docs
- fi
-
- if use emacs ; then
- elisp-compile editors/emacs/cocci.el || die
- fi
-}
-
-src_test() {
- emake check
- use python && emake pycocci-check
-}
-
-src_install() {
- default
-
- use doc && dodoc docs/manual/*.pdf
- newbashcomp scripts/spatch.bash_completion spatch
-
- if use emacs ; then
- elisp-install ${PN} editors/emacs/*
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-
- if use vim-syntax ; then
- newdoc editors/vim/README README-vim
- rm editors/vim/README || die
- insinto /usr/share/vim/vimfiles
- doins -r editors/vim/*
- fi
-
- use python && python_optimize
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/coccinelle/coccinelle-1.1.1-r5.ebuild b/dev-util/coccinelle/coccinelle-1.1.1-r5.ebuild
new file mode 100644
index 000000000000..63d4cf03a4a9
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-1.1.1-r5.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit autotools bash-completion-r1 elisp-common python-single-r1
+
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="https://coccinelle.gitlabpages.inria.fr/website/ https://gitlab.inria.fr/coccinelle/coccinelle"
+SRC_URI="https://gitlab.inria.fr/coccinelle/coccinelle/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs +ocamlopt pcre python test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# Test failures need investigation
+RESTRICT="strip !test? ( test ) test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/sexplib:=[ocamlopt(+)?]
+ dev-ml/menhir:=[ocamlopt?]
+ dev-ml/camlp4:=[ocamlopt?]
+ dev-ml/parmap:=[ocamlopt?]
+ dev-ml/findlib:=[ocamlopt?]
+ dev-ml/stdcompat:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+ pcre? (
+ dev-libs/libpcre
+ dev-ml/pcre-ocaml:=[ocamlopt?]
+ )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsextra
+ virtual/latex-base
+ dev-tex/hevea
+ )
+"
+
+DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-bash-completion.patch
+ "${FILESDIR}"/${P}-find-xxdate.patch
+ "${FILESDIR}"/${P}-shuffle.patch
+)
+SITEFILE=50coccinelle-gentoo.el
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use python ; then
+ # Fix python install location
+ sed -e "s:\$(LIBDIR)/python:$(python_get_sitedir):" \
+ -i Makefile || die
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-ocaml
+ --with-bash-completion="$(get_bashcompdir)"
+ --with-python="${EPYTHON}"
+
+ $(use_enable python)
+ $(use_enable pcre)
+ $(use_enable pcre pcre-syntax)
+ $(use_enable ocamlopt opt)
+ )
+
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ export TARGET_SPATCH=$(usev !ocamlopt 'byte-only')
+
+ emake VERBOSE=yes -j1 $(usex ocamlopt 'all.opt' 'all-dev')
+
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake VERBOSE=yes docs
+ fi
+
+ if use emacs ; then
+ elisp-compile editors/emacs/cocci.el || die
+ fi
+}
+
+src_test() {
+ # TODO: See Fedora's method?
+ # https://src.fedoraproject.org/rpms/coccinelle/blob/rawhide/f/coccinelle.spec#_231
+ emake VERBOSE=yes check $(usev python pycocci-check)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}" VERBOSE=yes -j1 install
+
+ if use python ; then
+ python_optimize
+ else
+ rm -rf "${ED}/usr/$(get_libdir)/${PN}/python" || die
+ fi
+
+ if use emacs ; then
+ elisp-install ${PN} editors/emacs/*
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ einstalldocs
+ use doc && dodoc docs/manual/*.pdf
+
+ newdoc editors/vim/README README-vim
+ rm editors/vim/README || die
+ insinto /usr/share/vim/vimfiles
+ doins -r editors/vim/*
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/coccinelle/files/coccinelle-1.1.1-bash-completion.patch b/dev-util/coccinelle/files/coccinelle-1.1.1-bash-completion.patch
new file mode 100644
index 000000000000..1958dbd498f4
--- /dev/null
+++ b/dev-util/coccinelle/files/coccinelle-1.1.1-bash-completion.patch
@@ -0,0 +1,19 @@
+--- a/scripts/spatch.bash_completion
++++ b/scripts/spatch.bash_completion
+@@ -34,7 +34,6 @@ __spatchcomp_1 ()
+ done
+ }
+
+-have spatch &&
+ _spatch()
+ {
+ local cur prev xspec
+@@ -89,8 +88,6 @@ _spatch()
+ complete -F _spatch -o bashdefault -o default -o nospace spatch \
+ || complete -F _spatch -o default -o nospace spatch
+
+-complete -F _spatch -o bashdefault -o default -o nospace spatch.opt \
+- || complete -F _spatch -o default -o nospace spatch.opt
+
+ # Local variables:
+ # mode: shell-script
diff --git a/dev-util/coccinelle/files/coccinelle-1.1.1-find-xxdate.patch b/dev-util/coccinelle/files/coccinelle-1.1.1-find-xxdate.patch
new file mode 100644
index 000000000000..0b8143f29cfd
--- /dev/null
+++ b/dev-util/coccinelle/files/coccinelle-1.1.1-find-xxdate.patch
@@ -0,0 +1,11 @@
+--- a/docs/manual/find-xxdate
++++ b/docs/manual/find-xxdate
+@@ -9,7 +9,7 @@
+ # Otherwise, a warning is printed on stderr and the script returns 1
+
+ file=xxdate.exe
+-directories="$(opam var hevea:lib) /usr/lib64/hevea /usr/share/hevea /usr/local/lib/hevea /opt/local/share/hevea"
++directories="/usr/lib/hevea /usr/lib64/hevea /usr/share/hevea /usr/local/lib/hevea /opt/local/share/hevea"
+
+ for dir in ${directories}; do
+ fullpath=${dir}/${file};
diff --git a/dev-util/coccinelle/files/coccinelle-1.1.1-shuffle.patch b/dev-util/coccinelle/files/coccinelle-1.1.1-shuffle.patch
new file mode 100644
index 000000000000..0b3059e02529
--- /dev/null
+++ b/dev-util/coccinelle/files/coccinelle-1.1.1-shuffle.patch
@@ -0,0 +1,12 @@
+--- a/Makefile 2024-06-06 08:37:24.033420168 +0200
++++ b/Makefile 2024-06-06 08:37:54.188080138 +0200
+@@ -283,7 +283,8 @@
+ byt-only byte-only byte : $(foreach tool,$(TOOLS),$(PREFIX_$(tool))$(tool))
+
+ .PHONY: install
+-install: install-spatch install-spgen install-python install-bash install-man
++install: install-spatch
++ $(MAKE) install-spgen install-python install-bash install-man
+
+ .PHONY: install-bash
+ install-bash:
diff --git a/dev-util/coccinelle/metadata.xml b/dev-util/coccinelle/metadata.xml
index 6f49eba8f496..313e852a9cce 100644
--- a/dev-util/coccinelle/metadata.xml
+++ b/dev-util/coccinelle/metadata.xml
@@ -1,5 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">coccinelle/coccinelle</remote-id>
+ </upstream>
</pkgmetadata>