summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/codeblocks/codeblocks-20.03-r7.ebuild')
-rw-r--r--dev-util/codeblocks/codeblocks-20.03-r7.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-util/codeblocks/codeblocks-20.03-r7.ebuild b/dev-util/codeblocks/codeblocks-20.03-r7.ebuild
index 7ba97f106804..ec7b50a3be12 100644
--- a/dev-util/codeblocks/codeblocks-20.03-r7.ebuild
+++ b/dev-util/codeblocks/codeblocks-20.03-r7.ebuild
@@ -5,7 +5,7 @@ EAPI=8
WX_GTK_VER="3.0-gtk3"
-inherit autotools flag-o-matic wxwidgets xdg
+inherit autotools flag-o-matic multiprocessing wxwidgets xdg
DESCRIPTION="The open source, cross platform, free C, C++ and Fortran IDE"
HOMEPAGE="https://codeblocks.org/"
@@ -85,6 +85,18 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_compile() {
+ if use contrib; then
+ if (( $(get_makeopts_jobs) > 8 )); then
+ emake -j8 # Bug 930819
+ else
+ emake
+ fi
+ else
+ emake
+ fi
+}
+
src_install() {
default
find "${ED}" -type f -name '*.la' -delete || die