summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/conf2struct')
-rw-r--r--dev-util/conf2struct/Manifest1
-rw-r--r--dev-util/conf2struct/conf2struct-1.0-r1.ebuild (renamed from dev-util/conf2struct/conf2struct-1.0.ebuild)4
-rw-r--r--dev-util/conf2struct/conf2struct-1.3-r1.ebuild (renamed from dev-util/conf2struct/conf2struct-1.3.ebuild)6
-rw-r--r--dev-util/conf2struct/conf2struct-1.5.ebuild32
-rw-r--r--dev-util/conf2struct/conf2struct-9999.ebuild6
-rw-r--r--dev-util/conf2struct/metadata.xml2
6 files changed, 42 insertions, 9 deletions
diff --git a/dev-util/conf2struct/Manifest b/dev-util/conf2struct/Manifest
index b4e7f3e69be0..ce6dc272ac0b 100644
--- a/dev-util/conf2struct/Manifest
+++ b/dev-util/conf2struct/Manifest
@@ -1,2 +1,3 @@
DIST conf2struct-1.0.tar.gz 57393 BLAKE2B 7de4be755ec764d96a321c68ca68b3156889e24f6894ba78b1c88cbeff84525331f1105040d61b1121ca01ece8d50a5aee2268eb73cde3ebbc8b62f679e2451b SHA512 31e8f350af740e79d97f4698dfec9b5e8a31a8a1cee30da0af753db26eda5b61379e9156e1cb492aef5068a4987d5e8202215323b83328e99705ae3ad3c09b81
DIST conf2struct-1.3.tar.gz 58599 BLAKE2B 19cd7beb2663342d1d0e282c2ce45557f97110edec02eb1a9e29f92aceedd5837175a0898655ae403f8992d2754dc5094dc5c3c85014b109b066703956c9ec6c SHA512 eae91f85e44905fdc4274c0cc090a0748ded15824b87cdc3d026ec849d1cb13d14fb9b1bfb57d76da4687173d106065263499c1705db24f53ad4e95ba1d96b3c
+DIST conf2struct-1.5.tar.gz 62276 BLAKE2B 67916a1888a2d6128ee68dea262ede6b35b8242d40f545c8af5a4cbe17d8bfc9150e0917057a792a29d9e32b39c77d67d401a06c77a206234162cb820afcfd31 SHA512 eafa7ed72a3bc8d885ccba961273161546b025074f6ed764818c90cd6f9b1de8a0ff09cef50457974a32208700ad47c43673004ed7ed647eb89de6e590be0be8
diff --git a/dev-util/conf2struct/conf2struct-1.0.ebuild b/dev-util/conf2struct/conf2struct-1.0-r1.ebuild
index 6891ffd1b8b0..c39a24cd4004 100644
--- a/dev-util/conf2struct/conf2struct-1.0.ebuild
+++ b/dev-util/conf2struct/conf2struct-1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -19,7 +19,7 @@ LICENSE="BSD-2"
SLOT="0"
IUSE=""
-RDEPEND="dev-libs/libconfig
+RDEPEND="dev-libs/libconfig:=
dev-perl/Conf-Libconfig"
DEPEND="${RDEPEND}"
diff --git a/dev-util/conf2struct/conf2struct-1.3.ebuild b/dev-util/conf2struct/conf2struct-1.3-r1.ebuild
index 6891ffd1b8b0..736fd4c6f1b3 100644
--- a/dev-util/conf2struct/conf2struct-1.3.ebuild
+++ b/dev-util/conf2struct/conf2struct-1.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,7 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/yrutschle/conf2struct.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~s390 ~x86"
+ KEYWORDS="~amd64 ~mips ~s390 ~x86"
SRC_URI="https://github.com/yrutschle/conf2struct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
@@ -19,7 +19,7 @@ LICENSE="BSD-2"
SLOT="0"
IUSE=""
-RDEPEND="dev-libs/libconfig
+RDEPEND="dev-libs/libconfig:=
dev-perl/Conf-Libconfig"
DEPEND="${RDEPEND}"
diff --git a/dev-util/conf2struct/conf2struct-1.5.ebuild b/dev-util/conf2struct/conf2struct-1.5.ebuild
new file mode 100644
index 000000000000..0065754b0770
--- /dev/null
+++ b/dev-util/conf2struct/conf2struct-1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Create C parsers for libconfig and command-line"
+HOMEPAGE="https://github.com/yrutschle/conf2struct/"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/yrutschle/conf2struct.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~m68k ~mips ~s390 ~x86"
+ SRC_URI="https://github.com/yrutschle/conf2struct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/libconfig:=
+ dev-perl/Conf-Libconfig"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+}
diff --git a/dev-util/conf2struct/conf2struct-9999.ebuild b/dev-util/conf2struct/conf2struct-9999.ebuild
index 6891ffd1b8b0..a235bcf015e5 100644
--- a/dev-util/conf2struct/conf2struct-9999.ebuild
+++ b/dev-util/conf2struct/conf2struct-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,7 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/yrutschle/conf2struct.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~s390 ~x86"
+ KEYWORDS="~amd64 -mips ~s390 ~x86"
SRC_URI="https://github.com/yrutschle/conf2struct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
@@ -19,7 +19,7 @@ LICENSE="BSD-2"
SLOT="0"
IUSE=""
-RDEPEND="dev-libs/libconfig
+RDEPEND="dev-libs/libconfig:=
dev-perl/Conf-Libconfig"
DEPEND="${RDEPEND}"
diff --git a/dev-util/conf2struct/metadata.xml b/dev-util/conf2struct/metadata.xml
index e969234c463c..3e3357f2963e 100644
--- a/dev-util/conf2struct/metadata.xml
+++ b/dev-util/conf2struct/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>candrews@gentoo.org</email>