summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cppcheck/cppcheck-2.6.2.ebuild')
-rw-r--r--dev-util/cppcheck/cppcheck-2.6.2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-util/cppcheck/cppcheck-2.6.2.ebuild b/dev-util/cppcheck/cppcheck-2.6.2.ebuild
index c7aad8ff5e63..a934618d7ad9 100644
--- a/dev-util/cppcheck/cppcheck-2.6.2.ebuild
+++ b/dev-util/cppcheck/cppcheck-2.6.2.ebuild
@@ -38,6 +38,9 @@ BDEPEND="
dev-libs/libxslt
virtual/pkgconfig
qt5? ( dev-qt/linguist-tools:5 )
+ test? (
+ htmlreport? ( dev-python/unittest-or-fail[${PYTHON_USEDEP}] )
+ )
"
src_prepare() {
@@ -68,6 +71,21 @@ src_compile() {
fi
}
+src_test() {
+ cmake_src_test
+
+ # TODO: Needs some hackery to find the right binary
+ #if use htmlreport ; then
+ # distutils-r1_src_test
+ #fi
+}
+
+python_test() {
+ pushd htmlreport || die
+ eunittest
+ popd || die
+}
+
src_install() {
cmake_src_install