summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/Manifest2
-rw-r--r--dev-util/cppcheck/cppcheck-1.86.ebuild113
-rw-r--r--dev-util/cppcheck/cppcheck-1.87.ebuild113
-rw-r--r--dev-util/cppcheck/cppcheck-9999.ebuild112
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.75-tinyxml2.patch55
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.85-ldflags.patch24
-rw-r--r--dev-util/cppcheck/files/cppcheck-9999-tinyxml2.patch56
7 files changed, 0 insertions, 475 deletions
diff --git a/dev-util/cppcheck/Manifest b/dev-util/cppcheck/Manifest
index 383ff755b285..51d80e257e39 100644
--- a/dev-util/cppcheck/Manifest
+++ b/dev-util/cppcheck/Manifest
@@ -1,4 +1,2 @@
-DIST cppcheck-1.86.tar.gz 2184186 BLAKE2B 8b488ec72d0998d6b037de2b1204373c8b3de475ad165bf108bb331399356cb0d1e20a7bc6f368f1a038ec886ad7a84ad694172d0a96a203a6877f3838c21001 SHA512 59cec55b8408e8f2e2e7172bce69350c248bc3185a0938b523c44a58f98b344e11aef957ec1b7a7b2bc7a876660b2683e51f54b76f0b550f9549497c29453655
-DIST cppcheck-1.87.tar.gz 2243258 BLAKE2B ffe42bfb2e896163678c5bb24e46ae2391ba8254cbe7c1c19c3c1b16cd38adf9c773de6aaefe70af08b9c1dca8b0b0b5e9939323368a2f81491fd6981ff18139 SHA512 b0149002b40260c1488904929296403722a66b84263b41d0097c3caed28265332766c114f0d1f378ea6c7e73ab973ea71ab89c6744f6cc818f22de08933e6766
DIST cppcheck-1.88.tar.gz 2364053 BLAKE2B b688974ff83019422cc5b2ec575d9838bdff4ada17d71fb3d436f07eea50429490c222659163b845667d98c0ec186b3288464827894e379fd017dd0c3fea645f SHA512 fa4ede0665546341af0ba3dae09a00b6efae09ec7838c616c580be01ff6902594d61168a059539779be0c78e1708d2bd9c8e7987dd0bb67dc8fa332a10d1de6a
DIST cppcheck-2.2.tar.gz 3561406 BLAKE2B e436de4bec5412a18f013c8557a966c28c14edcd07fbb80eb53a897848d15f32afc180798ea1a074742f896b15d4020755c104b87dc8f82252121b58a92b92dc SHA512 d766187a69d6aa839e072e3c0ed44009621ca8492504257288ca2f49774f705a1ebcf2957f0801ac6eab2ffbdd845e9237f1213f85c6d0fcdbf16b1e7c690327
diff --git a/dev-util/cppcheck/cppcheck-1.86.ebuild b/dev-util/cppcheck/cppcheck-1.86.ebuild
deleted file mode 100644
index 03e138c82501..000000000000
--- a/dev-util/cppcheck/cppcheck-1.86.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1 qmake-utils toolchain-funcs
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="https://github.com/danmar/cppcheck"
-SRC_URI="https://github.com/danmar/cppcheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 hppa ~ppc64 sparc x86"
-IUSE="htmlreport pcre qt5"
-
-RDEPEND="
- dev-libs/tinyxml2:=
- htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
- pcre? ( dev-libs/libpcre )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.75-tinyxml2.patch
- "${FILESDIR}"/${PN}-1.85-ldflags.patch
-)
-
-src_prepare() {
- default
-
- rm -r externals/tinyxml || die
-}
-
-src_configure() {
- tc-export CXX PKG_CONFIG
- export LIBS="$(${PKG_CONFIG} --libs tinyxml2)"
-
- emake dmake
- ./dmake || die
-
- if use pcre ; then
- sed -e '/HAVE_RULES=/s:=no:=yes:' \
- -i Makefile || die
- fi
-
- if use qt5 ; then
- pushd gui || die
- eqmake5
- popd || die
- fi
-}
-
-src_compile() {
- emake ${PN} man \
- CFGDIR="${EROOT}/usr/share/${PN}/cfg" \
- DB2MAN="${EROOT}/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
-
- if use qt5 ; then
- pushd gui || die
- emake
- popd || die
- fi
-
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_test() {
- # safe final version
- mv -v ${PN}{,.final} || die
- mv -v lib/library.o{,.final} || die
- mv -v cli/cppcheckexecutor.o{,.final} || die
- #trigger recompile with CFGDIR inside ${S}
- emake check CFGDIR="${S}/cfg"
- # restore
- mv -v ${PN}{.final,} || die
- mv -v lib/library.o{.final,} || die
- mv -v cli/cppcheckexecutor.o{.final,} || die
-}
-
-src_install() {
- # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
- emake install DESTDIR="${ED}"
-
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt5 ; then
- dobin gui/${PN}-gui
- dodoc gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_install
- popd || die
- find "${D}" -name "*.egg-info" -delete
- else
- rm "${ED}/usr/bin/cppcheck-htmlreport" || die
- fi
- doman ${PN}.1
- dodoc -r triage
-}
diff --git a/dev-util/cppcheck/cppcheck-1.87.ebuild b/dev-util/cppcheck/cppcheck-1.87.ebuild
deleted file mode 100644
index cd7a61d7ca8b..000000000000
--- a/dev-util/cppcheck/cppcheck-1.87.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-inherit distutils-r1 qmake-utils toolchain-funcs
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="https://github.com/danmar/cppcheck"
-SRC_URI="https://github.com/danmar/cppcheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
-IUSE="htmlreport pcre qt5"
-
-RDEPEND="
- dev-libs/tinyxml2:=
- htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
- pcre? ( dev-libs/libpcre )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.75-tinyxml2.patch
- "${FILESDIR}"/${PN}-1.85-ldflags.patch
-)
-
-src_prepare() {
- default
-
- rm -r externals/tinyxml || die
-}
-
-src_configure() {
- tc-export CXX PKG_CONFIG
- export LIBS="$(${PKG_CONFIG} --libs tinyxml2)"
-
- emake dmake
- ./dmake || die
-
- if use pcre ; then
- sed -e '/HAVE_RULES=/s:=no:=yes:' \
- -i Makefile || die
- fi
-
- if use qt5 ; then
- pushd gui || die
- eqmake5
- popd || die
- fi
-}
-
-src_compile() {
- emake ${PN} man \
- CFGDIR="${EROOT}/usr/share/${PN}/cfg" \
- DB2MAN="${EROOT}/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
-
- if use qt5 ; then
- pushd gui || die
- emake
- popd || die
- fi
-
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_test() {
- # safe final version
- mv -v ${PN}{,.final} || die
- mv -v lib/library.o{,.final} || die
- mv -v cli/cppcheckexecutor.o{,.final} || die
- #trigger recompile with CFGDIR inside ${S}
- emake check CFGDIR="${S}/cfg"
- # restore
- mv -v ${PN}{.final,} || die
- mv -v lib/library.o{.final,} || die
- mv -v cli/cppcheckexecutor.o{.final,} || die
-}
-
-src_install() {
- # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
- emake install DESTDIR="${ED}"
-
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt5 ; then
- dobin gui/${PN}-gui
- dodoc gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_install
- popd || die
- find "${D}" -name "*.egg-info" -delete
- else
- rm "${ED}/usr/bin/cppcheck-htmlreport" || die
- fi
- doman ${PN}.1
- dodoc -r tools/triage
-}
diff --git a/dev-util/cppcheck/cppcheck-9999.ebuild b/dev-util/cppcheck/cppcheck-9999.ebuild
deleted file mode 100644
index b5bb8e433e7b..000000000000
--- a/dev-util/cppcheck/cppcheck-9999.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
-inherit distutils-r1 git-r3 qmake-utils toolchain-funcs
-
-DESCRIPTION="Static analyzer of C/C++ code"
-HOMEPAGE="https://github.com/danmar/cppcheck"
-EGIT_REPO_URI="https://github.com/danmar/cppcheck"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS=""
-IUSE="htmlreport pcre qt5"
-
-RDEPEND="
- dev-libs/tinyxml2:=
- htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
- pcre? ( dev-libs/libpcre )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-9999-tinyxml2.patch
-)
-
-src_prepare() {
- default
-
- rm -r externals/tinyxml || die
-}
-
-src_configure() {
- tc-export CXX PKG_CONFIG
- export LIBS="$(${PKG_CONFIG} --libs tinyxml2)"
-
- emake dmake
- ./dmake || die
-
- if use pcre ; then
- sed -e '/HAVE_RULES=/s:=no:=yes:' \
- -i Makefile || die
- fi
-
- if use qt5 ; then
- pushd gui || die
- eqmake5
- popd || die
- fi
-}
-
-src_compile() {
- emake ${PN} man \
- CFGDIR="${EROOT}/usr/share/${PN}/cfg" \
- DB2MAN="${EROOT}/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
-
- if use qt5 ; then
- pushd gui || die
- emake
- popd || die
- fi
-
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_compile
- popd || die
- fi
-}
-
-src_test() {
- # safe final version
- mv -v ${PN}{,.final} || die
- mv -v lib/library.o{,.final} || die
- mv -v cli/cppcheckexecutor.o{,.final} || die
- #trigger recompile with CFGDIR inside ${S}
- emake check CFGDIR="${S}/cfg"
- # restore
- mv -v ${PN}{.final,} || die
- mv -v lib/library.o{.final,} || die
- mv -v cli/cppcheckexecutor.o{.final,} || die
-}
-
-src_install() {
- # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
- emake install DESTDIR="${ED}"
-
- insinto "/usr/share/${PN}/cfg"
- doins cfg/*.cfg
- if use qt5 ; then
- dobin gui/${PN}-gui
- dodoc gui/{projectfile.txt,gui.${PN}}
- fi
- if use htmlreport ; then
- pushd htmlreport || die
- distutils-r1_src_install
- popd || die
- find "${D}" -name "*.egg-info" -delete
- else
- rm "${ED}/usr/bin/cppcheck-htmlreport" || die
- fi
- doman ${PN}.1
- dodoc -r tools/triage
-}
diff --git a/dev-util/cppcheck/files/cppcheck-1.75-tinyxml2.patch b/dev-util/cppcheck/files/cppcheck-1.75-tinyxml2.patch
deleted file mode 100644
index 67e4ac65a410..000000000000
--- a/dev-util/cppcheck/files/cppcheck-1.75-tinyxml2.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/gui/gui.pro
-+++ b/gui/gui.pro
-@@ -19,6 +19,7 @@
- DEFINES += CPPCHECKLIB_IMPORT
- }
- LIBS += -L$$PWD/../externals
-+LIBS += $(shell $(PKG_CONFIG) --libs tinyxml2)
-
- DESTDIR = .
- RCC_DIR = temp
---- a/tools/dmake.cpp
-+++ b/tools/dmake.cpp
-@@ -123,7 +123,6 @@
-
- std::vector<std::string> extfiles;
- extfiles.push_back("externals/simplecpp/simplecpp.cpp");
-- extfiles.push_back("externals/tinyxml/tinyxml2.cpp");
-
- std::vector<std::string> clifiles;
- getCppFiles(clifiles, "cli/", false);
-@@ -172,7 +171,6 @@
- std::ofstream fout1("test/testfiles.pri");
- if (fout1.is_open()) {
- fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
-- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
- fout1 << "\n\nSOURCES += ";
- for (unsigned int i = 0; i < testfiles.size(); ++i) {
- const std::string filename(testfiles[i].substr(5));
-@@ -337,9 +335,9 @@
- << "endif\n\n";
-
- makeConditionalVariable(fout, "PREFIX", "/usr");
-- makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -Iexternals/simplecpp -Iexternals/tinyxml");
-- makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -Iexternals/simplecpp -Iexternals/tinyxml");
-- makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -Iexternals/simplecpp -Iexternals/tinyxml");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -Iexternals/simplecpp");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -Iexternals/simplecpp");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -Iexternals/simplecpp");
-
- fout << "BIN=$(DESTDIR)$(PREFIX)/bin\n\n";
- fout << "# For 'make man': sudo apt-get install xsltproc docbook-xsl docbook-xml on Linux\n";
---- a/externals/externals.pri
-+++ b/externals/externals.pri
-@@ -1,8 +1,5 @@
--INCLUDEPATH += $${PWD}/simplecpp \
-- $${PWD}/tinyxml
-+INCLUDEPATH += $${PWD}/simplecpp
-
--HEADERS += $${PWD}/simplecpp/simplecpp.h \
-- $${PWD}/tinyxml/tinyxml2.h
-+HEADERS += $${PWD}/simplecpp/simplecpp.h
-
--SOURCES += $${PWD}/simplecpp/simplecpp.cpp \
-- $${PWD}/tinyxml/tinyxml2.cpp
-+SOURCES += $${PWD}/simplecpp/simplecpp.cpp
diff --git a/dev-util/cppcheck/files/cppcheck-1.85-ldflags.patch b/dev-util/cppcheck/files/cppcheck-1.85-ldflags.patch
deleted file mode 100644
index 84e892827125..000000000000
--- a/dev-util/cppcheck/files/cppcheck-1.85-ldflags.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/tools/dmake.cpp
-+++ b/tools/dmake.cpp
-@@ -363,10 +363,10 @@
- fout << ".PHONY: run-dmake tags\n\n";
- fout << "\n###### Targets\n\n";
- fout << "cppcheck: $(LIBOBJ) $(CLIOBJ) $(EXTOBJ)\n";
-- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
-+ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LDFLAGS) $(RDYNAMIC) $(LIBS)\n\n";
- fout << "all:\tcppcheck testrunner\n\n";
- fout << "testrunner: $(TESTOBJ) $(LIBOBJ) $(EXTOBJ) cli/threadexecutor.o cli/cmdlineparser.o cli/cppcheckexecutor.o cli/filelister.o\n";
-- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
-+ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LDFLAGS) $(RDYNAMIC) $(LIBS)\n\n";
- fout << "test:\tall\n";
- fout << "\t./testrunner\n\n";
- fout << "check:\tall\n";
-@@ -380,7 +380,7 @@
- fout << "generate_cfg_tests: tools/generate_cfg_tests.o $(EXTOBJ)\n";
- fout << "\tg++ -Iexternals/tinyxml -o generate_cfg_tests tools/generate_cfg_tests.o $(EXTOBJ)\n";
- fout << "reduce:\ttools/reduce.o $(LIBOBJ) $(EXTOBJ)\n";
-- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
-+ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LDFLAGS) $(RDYNAMIC) $(LIBS)\n\n";
- fout << "clean:\n";
- fout << "\trm -f build/*.o lib/*.o cli/*.o test/*.o tools/*.o externals/*/*.o testrunner reduce dmake cppcheck cppcheck.1\n\n";
- fout << "man:\tman/cppcheck.1\n\n";
diff --git a/dev-util/cppcheck/files/cppcheck-9999-tinyxml2.patch b/dev-util/cppcheck/files/cppcheck-9999-tinyxml2.patch
deleted file mode 100644
index 7a2a037ab377..000000000000
--- a/dev-util/cppcheck/files/cppcheck-9999-tinyxml2.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/externals/externals.pri
-+++ b/externals/externals.pri
-@@ -1,9 +1,6 @@
- INCLUDEPATH += $${PWD} \
-- $${PWD}/simplecpp \
-- $${PWD}/tinyxml
-+ $${PWD}/simplecpp
-
--HEADERS += $${PWD}/simplecpp/simplecpp.h \
-- $${PWD}/tinyxml/tinyxml2.h
-+HEADERS += $${PWD}/simplecpp/simplecpp.h
-
--SOURCES += $${PWD}/simplecpp/simplecpp.cpp \
-- $${PWD}/tinyxml/tinyxml2.cpp
-+SOURCES += $${PWD}/simplecpp/simplecpp.cpp
---- a/gui/gui.pro
-+++ b/gui/gui.pro
-@@ -15,6 +15,7 @@ contains(LINKCORE, [yY][eE][sS]) {
- DEFINES += CPPCHECKLIB_IMPORT
- }
- LIBS += -L$$PWD/../externals
-+LIBS += $(shell $(PKG_CONFIG) --libs tinyxml2)
-
- DESTDIR = .
- RCC_DIR = temp
---- a/tools/dmake.cpp
-+++ b/tools/dmake.cpp
-@@ -122,7 +122,6 @@ int main(int argc, char **argv)
-
- std::vector<std::string> extfiles;
- extfiles.push_back("externals/simplecpp/simplecpp.cpp");
-- extfiles.push_back("externals/tinyxml/tinyxml2.cpp");
-
- std::vector<std::string> clifiles;
- getCppFiles(clifiles, "cli/", false);
-@@ -171,7 +170,6 @@ int main(int argc, char **argv)
- std::ofstream fout1("test/testfiles.pri");
- if (fout1.is_open()) {
- fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
-- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
- fout1 << "\n\nSOURCES += ";
- for (unsigned int i = 0; i < testfiles.size(); ++i) {
- const std::string filename(testfiles[i].substr(5));
-@@ -335,9 +333,9 @@ int main(int argc, char **argv)
- << "endif\n\n";
-
- makeConditionalVariable(fout, "PREFIX", "/usr");
-- makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -isystem externals -isystem externals/simplecpp -isystem externals/tinyxml");
-- makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -isystem externals/simplecpp -isystem externals/tinyxml");
-- makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -isystem externals/simplecpp -isystem externals/tinyxml");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -isystem externals -isystem externals/simplecpp");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -isystem externals/simplecpp");
-+ makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -isystem externals/simplecpp");
-
- fout << "BIN=$(DESTDIR)$(PREFIX)/bin\n\n";
- fout << "# For 'make man': sudo apt-get install xsltproc docbook-xsl docbook-xml on Linux\n";